Asterisk, SIP, Linphone

I’m attempting to create a new PBX setup for my company since the old box it was running on died. I’ve never done anything with telephony before (other than dialup back when) so this is all new to me. So far, I’ve got what looks like a properly functioning install of Asterisk, adherent to the From Source wiki page. The only caveats are that I had to downgrade DAHDI to 2.9.01 to work with my Sangoma card’s drivers and PJProject compiled fine, but Asterisk’s configure script didn’t seem to concern itself with the libraries.

As I’m following the Hello World instructions, though, I’ve run into some issues. /etc/asterisk/extensions.conf and /etc/asterisk/sip.conf are modified per the wiki page:

root@soundwave:~$ cat /etc/asterisk/extensions.conf [from-internal] exten = 100,1,Answer() same = n,Wait(1) same = n,Playback(hello-world) same = n,Hangup()

[code]root@soundwave:~$ cat /etc/asterisk/sip.conf


And pjsip.conf doesn’t exist because Asterisk isn’t aware of PJProject.

Next, I attempted to use Zoiper, but couldn’t get it to run on my laptop due to it requiring elements of GTK2 I don’t have. I finally wound up installing Linphone and that seems to run just fine. However, when I give it all of the information above, it comes back with “Service unavailable.” What’s more, I don’t see any output from the Asterisk CLI on the server.

What should my next diagnostic step be? Thanks in advance. =)

sip set debug on

I get no such command for “sip set debug on” as well as “sip debug” from the asterisk CLI.

You didn’t build (typically because you are missing an encryption library’s development package, or you have a fatally flawed sip.conf. Both should be evident from the logs during start-up, although you can also check by using:

module reload chan_sip

and if that says not loaded

modules load chan_sip

Thank you for your fast replies. You’re right that didn’t exist.

I looked through make menuconfig and chan_sip is selected, as is res_crypto. I couldn’t find a menu option for res_http_websocket, though. I also do have openssl and libssl-dev installed.

So I ran make again, and the module built. I ran make install and then restarted asterisk and upon bringing up the CLI, saw our SIP phones failing to log in due to the demo config.

This is some very bright news! Thank you very much, David. I’ll come back and mark this thread as closed as soon as I’ve verified functionality.