Asterisk recordings: playback problem

Greetings and salutations,

I have set up call recording with “ulaw” format, and recordings do have a .ulaw extension, but I can’t play them back, with ulaw settings on CoolEdit I can hear the audio play way too fast, I can’t make out the words.

What’s the proper way to play these back? What is their REAL format, since it’s obviously not vanilla ulaw?

Generally, is there a utility that can identify the format of an audio file?


if you save the recordings as wav you can playback the recordings with any media player.

It is raw G.711 mu-law with no meta data. If Cool edit is playing them back too fast, it is broken, as mu-law is only ever used at 8kHZ mono, in practice.

I recorded with ulaw setting and it played back too fast, yesterday I switched to “wav” (not “WAV”) and it STILL plays back too fast, I have seen asterisk-developer postings identifying it as a bug, something about problematic recording with BRI cards, there’s no question about it, it’s not working right. Plus some parts of the audio play back fine, so the problem is 100% within Asterisk and not CoolEdit or any other player I have tried.

In that case you are going to have to tell us a lot more about your configuration.

The only thing I can think of is that you don’t have a valid master timing source.

I’ll gladly tell you anything you think is relevant.

Where would I find that timing source setting?

As you have dahdi, I would suggest trying the various dahdi show options. The source for non-dahdi purposes is set in the compile time options, using make menuconfig.

It’s only a guess though. I’ve never experienced problems with sample rates on recordings.