Asterisk picks up on first ring, but ext. rings on second


#1

Hi, when * asterisk receives a pots call it picks up on the first ring, but my ext. rings on the second ring. can someone point me in the right direction? i have set usecallerid=no. i don’t know what else to try. any suggestions at all would be greatly appreciated!


#2

why have it pick up at all ? why not leave it ringing until the extensions answers and then do a bridge ?

i’m guessing by your post you’re using A@H ? do you have fax detection turned on ? what are you using for FXO ? if using a digium card, what does your zapata look like ?


#3

oh your right, asterisks not picking it up, but asterisk detects the first ring, it shows in FOP. then on the second ring fop shows the ext. ringing, and thats when i hear the first ring at my ext. but for the caller its their second ring. i have diabled the fax detection as well, by using: faxdetect=no.

I’m using a Digium tdm400p with fxo modules. in a PIII 550mhz machine. This is asterisk@home, you think it would do what i want if i installed asterisk manualy?

heres my zapata config files:

;zapata.conf
; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=no
hidecallerid=no
callwaiting=no
usecallingpres=no
callwaitingcallerid=no
threewaycalling=no
transfer=no
cancallforward=no
callreturn=no
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=yes

;faxdetect=both
;faxdetect=incoming
;faxdetect=outgoing
faxdetect=no

;Include genzaptelconf configs
#include zapata-auto.conf

;Include AMP configs
#include zapata_additional.conf

;zapata-auto.conf file:

; Autogenerated by /usr/local/sbin/genzaptelconf – do not hand edit
; Zaptel Channels Configurations (zapata.conf)
;
; This is not intended to be a complete zapata.conf. Rather, it is intended
; to be #include-d by /etc/zapata.conf that will include the global settings
;
callerid=asreceived

; Span 1: WCTDM/0 "Wildcard TDM400P REV I Board 1"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 1
context=from-pstn
group=0
channel => 1

signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 2
context=from-pstn
group=0
channel => 2

signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 3
context=from-pstn
group=0
channel => 3

signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 4
context=from-pstn
group=0
channel => 4

; Span 2: ZTDUMMY/1 “ZTDUMMY/1 1”


#4

any ideas of what i should try to test to get this working? or is this just a limitation of using analog lines?


#5

i’ve never noticed any significant delay with my system, but then i don’t call myself !!

have you followed your [from-pstn] context through to see if AMP has used an Wait() statements that might be introducing delay ?


#6

can you try to call yourself? it would help me a lot… also i get 15 seconds of silence when i dial out before both parties start to ring, but they are in sync. that delay is also as annoying as the incoming, almost…


#7

call myself ?? not at 4am i can’t. i don’t think i’d be popular !!

have you gone through your logs and configs looking for delays ? both for incoming and outgoing calls ?


#8

hehe, no not 4am… just if you can it would help me to know if its a common problem… i have tried just plain dial() functions and it still has the delay…


#9

I just fixed the same problem n my asterisk installation. You are using AAH so i’m do know how to fix this with AAH but here is the resulat of my research.

Here is a diaplan causing an ring delay ( my ext. rings on the second ring) because, Asterisk answer the line AFTER the first ring.

exten => s,1,Answer
exten => s,2,Dial(SIP/201&SIP/202,30)

So, in this exemple, the line ring, * answer the line after the first ring then dial my extension.

if you want this problem to be fixed, you have to let the ZAP channel ring your extension this way :

exten => s,1,Dial(SIP/201&SIP/202,30)

this way, the Zap Channel will enter the s extension and ring your extension. Asterisk isn’t going to answer the call until the end of the timeout if any.

I don’t know how you can manage this in AAH but It’S almost sure that the problem comve from this configuration.


#10

it doesn’t seem like asterisk is answering the phone first. it just passes the ring to the ext. like in your second example, but theres still a delay… im playing with differnt line start switchs i.e. from kewlstart to linestart. this seems to have some affect on the delay. im not really sure what the differences of these options are :smile: but it seems like im getting somewhere playing with them… im going to play more tomarow…


#11

To see if Asterisk is asnwering the call, try something, call your baeline with a cell phone and after your first ring extension, hangup the cell phone. If the extension is still ringing until the definited timeout, this is because Asterisk is answering the line.

On the other hand, if the ext stop ringing after you hangup ( immediatly or 1 ring later), Asterisk isn’t answeraing the line.

If you are in north America, I think it’s preferable to choose KewlStart.