Asterisk only successfully registers once

I’m running asterisk on a DigitalOcean server, it’s been running just fine for months. I haven’t touched any of the pjsip configs in months either. It’s worked great.

Recently I’ve noticed that inbound calls have been failing. Outbound works great, but inbound doesn’t anymore. Now if I stop and restart asterisk it begins working again and successfully registers and inbound calls work but after some amount of minutes I get this warning on the console

 WARNING[21325]: res_pjsip_outbound_registration.c:1006 handle_registration_response: Fatal response '401' received from 'sip:###@###:5060' on registration attempt to 'sip:###@###:5060', stopping outbound registration

The most infuriating thing is I haven’t done or changed anything and it successfully registers the first time. Why can’t it register anytime after? Why is it all of a suddenly getting 401? What has happened?

Until I can get this fixed my entire phone system is offline on inbound calls meaning nobody can call me. I’ve opened a ticket with my did provider but it could be 1+ days before they’ll get back with me and it’s likely not going to be anything useful. I don’t even know where the problem is coming from, my end or theirs.

[auth]
type=auth
auth_type=userpass
password=###
username=###

[reg]
type=registration
outbound_auth=auth
server_uri=sip:###@###:5060
client_uri=sip:###@###:5060

It seems to be from them, they’re rejecting the registration for some reason after a period of time. There are options that can be set[1] to control the behavior. In this case fatal_retry_interval which will cause the REGISTER to be attempted again after a period of time despite the fatal response.

[1] https://github.com/asterisk/asterisk/blob/master/configs/samples/pjsip.conf.sample#L1198

1 Like

I’ve added

expiration = 300
auth_rejection_permanent = no
retry_interval = 30
forbidden_retry_interval = 60
fatal_retry_interval = 120
max_retries = 120

Temporarily until I hear back from them. So far it seems to be working and holding but we’ll see.

1 Like

Well they replied and as figured it was something entirely useless

Hello,

We do not support pjsip. Do you have any registration issues using a sip trunk?

Please advise,
David
Network Technician

Correct me if I’m wrong but isn’t pjsip just another sip implementation offering different experiences and range of features but overall communication over the same protocol. It doesn’t speak it’s own protocol language. In the end it’s just all sip.

To me this comes off as “we don’t really understand this new crap out there can’t you just use real sip” when the advice I’m getting on here is it’s likely on there end to begin with especially since this setup has worked unchanged for months.

It doesn’t matter anyways so far, as of now the new changes I made above are holding and working just fine.

SIP is SIP either way. PJSIP is also widely used in clients so if there were some sort of core problem, it’d be seen by many and get fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.