Asterisk only for call setup

Its about Asterisk version 1.2.8 on CentOs 4.3

Cisco Callmanager is only used for the call-setup.
The RTP stream is not going via the Cisco Callmanager.
If it is possible to establish this with the Asterisk PBX it will increase performance and can handle more concurrent calls.


  1. Is this also possible for the Asterisk PBX

  2. What setting or configuration do I have to do ?

Thanks in advance

I read some articles about Asterisk involved in RTP streams.
The proposal was to set “canreinvite=no” .
I tried “canreinvite=no” and “canreinvite=yes” and I sniffed the communication between two phones and saw in both cases the RTP streams goes through Asterisk.


  1. Is this, in my case, not possible due to my version Asterisk 1.2.8
    and CentOS 4.3 ?
  2. Or is there another setting responsible for the RTP stream path ?

Thanks in advance !

Problem solved !!

I’m working with Asterisk 1.2.8 and CentOS 4.3 .
A few months ago i used

in sip.conf

in extensions.conf
exten => exten => 10012,1,Macro(zapdial,${EXTEN},SIP/10012)

(not only for the phone 10012 but also 10014 and all the SIP phones )
I did this because I was able to do unconditionally callforwarding with *21 ( Netherlands ) instead when using Dial(SIP/${EXTEN, …)


exten => exten => 10012,1,Dial(SIP/${EXTEN},10)

It was not possible to do callforwarding with *21 .
So, I changed it back to Dial(SIP/${EXTEN, …) with the knowledge I can’t do unconditionally callforwarding.

When I do a call between 2 SIP phones I see on the sniffer the Asterisk is only used for setting up the call and the RTP stream goes only between the two SIP phones.
This is the result I wanted.
I think the unconditionally callforwarding is a problem of the SIP version on the Asterisk I have inherited.

Now I can continue with my asterisk stress tests to gain a higher concurrent calls with RTP stream and DTMF injection.

I thank all the readers who read my problem and have tried to find a solution for it !