Help! direct RTP

I have Asterisk and 2 mobile phones N80 in the same subnet. I can make VoIP calls between the terminals but when i capture the traffic I see that the RTP packets dont go direct from one terminal to the other but through the asterisk. I want it to be direct RTP. I have tried ‘canreinvite=yes’ but still not working. When I type ‘sip show settings’ I dont get any Direct RTP option at General Settings. I’ve also checked that any of these are happening:
-If one of the clients is configured with canreinvite=NO, Asterisk will not issue a re-invite at all.
-If the clients use different codecs, Asterisk will not issue a re-invite.
-If the Dial() command contains ‘‘t’’, ''T", “h”, “H”, “w”, “W” or “L” (with multiple arguments) Asterisk will not issue a re-invite.

What can I do???

If you’re using * 1.4 try directrtpsetup; from my sip.conf:

;directrtpsetup=yes             ; Enable the new experimental direct RTP setup. This sets up
                                ; the call directly with media peer-2-peer without re-invites.
                                ; Will not work for video and cases where the callee sends
                                ; RTP payloads and fmtp headers in the 200 OK that does not match the
                                ; callers INVITE. This will also fail if canreinvite is enabled when
                                ; the device is actually behind NAT.


Marco Bruni