Asterisk not working how Asterisk: Future of Telephony says

Hi, I’m currently on the Adding Logic to the Dialplan section of the online book, Asterisk: The Future of Telephony. I have connected an IP phone into my home network and I have managed to get it to treat the Asterisk server as its SIP server.

I have managed to get the “enter the extension of the number you are trying to reach” sound file to play if you call the server (using the s extension), however after playing the sound file, it immediate hangs up, and the Asterisk command console shows “Auto fallthrough, channel ‘SIP/helios-xxxx’ status is ‘UNKNOWN’”, and it doesn’t move onto the t extension after 10 seconds, as the book says it should.
Any idea what’s going on?

set
autofallthrough=no
in zapata.conf

Then reload chan_zap.so

But i’m not using zapata, I’m using SIP, should that still need to be done?

I added it to zapata.conf right at the end, since it isn’t actually mentioned anywhere in the file, and it complained when I tried to reload it:

WARNING[2521]: chan_zap.c:12592 setup_zap:ignoring autofallthrough

(it also ignored switchtype, signalling and rxwink before hand)

remove the line from zapata.conf and paste it in the dialplan i.e
extensions.conf under the ‘general’ context

You are probably trying to use responsetimout that has been depreciated.
Take a look there and tell me if this fix your problem.

forums.digium.com/viewtopic.php? … e1d6b1c59a

I ran into the same thing…those darn pesky docs. My biggest complaint when I started was that “TFOT” and many other docs start out as if you have loads of hardware, zaptel for example. And even by some of the answers posted (well meaning…this is a good forum to learn *) are making that same assumption.

I’m a cheap bum with not much disposable income but * peeked my interest and I decided to give it a run. Heck, the promo’s say “Needs no special hardware”. So as long as it’s free, let’s have a go at it.

I started my system the same way you did. No hardware outside of a sound card that was already in the machine. I eventually got an IP phone and it made testing lot’s easier than with the softphones although I still say I love X-Lite. But to address your question…

The “TFOT” is not in error. The methods described therein work. I have SIP setup for most of my extensions and a softphone (IDEFISK) that runs IAXy for me. My * box has everything running smoothly and I did not need one single thing with zaptel to make it work, unless you count the superfulous stuff like music-on-hold and conference rooms. To get a totally SIP setup going is not hard…but I agree with you, the docs are not straight-forward on this unless you’re prepared to dig deep into them.

PM me and I’ll see if I can help you further.

.

yea i was just having this same problem and by switching from Response timeout to WaitExten(10) the problem was fixed.

so try doing

s,1,Background(your-file)
s,2,WaitExten(10)
more extensions

t,1,Goto(s,1)