Asterisk not enforcing Remote-Party-Id (privacy=full)


#1

Hi,
I have a problem, Asterisk doesn’t seem to always enforce the privacy=full in the Remote-Party-Id header of SIP messages…

Let me explain, we foward calls to asterisk for Voicemail,
Asterisk does receive the number of the caller, but also “privacy=full” in Remote-Party-Id header…
Call goes to voicemail, everything fine except, that in the email i receive
i do see the number of the caller!
So both ${VM_CALLERID} AND ${VM_CIDNUM} send me the number, even if the call was supposed to be private.

I did stumbled upon the sendrpid and trustrpid option in SIP.conf, and set both of those to =yes in [general] section, but it changed nothing.

Is there a way in the dial plan (extensions.conf) to know if a call was set ‘privacy=full’ ? if so, then maybe i could empty the CALLERIDNUM and it would be ok…
And if it is possible to ‘test’ for privacy=full, is it also possible to set it on an outboud call ? (i guess i could by making 2 matching peers one for private call with option restrictcid=yes ?)

Thanks you all for any information, or idea about this…
Even if it involves modifing the source code.

PS: we are currently running * 1.2, with at the moment, only SIP (no T1/E1 cards yet)

PPS: we also use asterisk to do toll bypass and the same problem happens… since i set the outbound CallerIDNUM to the one i received…


#2

Nobody got any clues on this?