Asterisk is not playing messages

Hi,
Hope you all will be fine.When i try to play a newly recorded message the asterisk didn’t play it. The message is

But when i try to listen old messages it works fine.The files are also creating in the folder both txt and wav. Also asterisk is telling the recording time wrong. Alos it take a long time to play a message. I want to ask is Asterisk taking long time because of bandwidth. I am running asterisk on low bandwidth.

Thanks

Are permissions correct on the file? Have you tried .gsm format? I don’t really know why without looking at logs. Is that message the only log?

Hi,
Thanks for your reply.Thank you very much. I am unable to figure out why this is happening.I am running asterisk 1.4.18.1 on centos 4.7.Anyways actually when i connect to Xlite and try to listen the messages the logs are.

and when the same thing when i try using land line then the logs are

In both cases the messages is not playing. I want to ask is this firewall issue. Because i use nat=yes for every user in my sip.conf. I also check the Iptables and the output is

I am storing voice messages to database.First when i record sound then it goes to /var/spool/asterisk/voicemail/220/brights/INBOX/msg0000.txt and other is msg0000.wav and after sometime it removes from this folder and go to database
The permissions are for txt : rw-r–r--
for wav : rwxr-xr-x

One strange thing that i also noted is that i recorded a new message and then when i tried to listen it using landline then asterisk played the message but the old messages are still not playing. Then i recorded another new message using landline and now try to listen it using Xlite and the logs are

Also this is my extensions.conf

suppose i dial extension 220. Against 220 i set email address basit_mahmood@netkarachi.com, but voicemail isn’t going to this address but going to my root account.Can you tell me why it is going to my root account instead of sending it to the email address. The root contain this mail.

The mail logs are

One more thing before playing message asterisk take long time. Is this because of bandwidth. Actually i am using very low bandwidth.

I know i ask too many thing but i am stuck here for many days. Please try to help me. Thanks :confused:

Thanks :frowning: