Voicemail not played after one succesful call

Good morning,

when routing a call to voicemail the very first call is played correctly. All following calls don’t play the audio. In the CLI ii is shown that the voicemal file is played but no audio and Asterisk hangs up regardless of talking into the headset or not.

-- Executing [022528301470@Telekom_in:1] Dial("PJSIP/Telekom_in-00000006", "SCCP/29,30") in new stack
   > SCCP: sccp_requestChannel returned Line 29 not currently registered -> Try again later

[Feb 6 09:25:42] WARNING[25311][C-00000007]: app_dial.c:2530 dial_exec_full: Unable to create channel of type ‘SCCP’ (cause 44 - Requested channel not available)
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [022528301470@Telekom_in:2] VoiceMail(“PJSIP/Telekom_in-00000006”, “29@voicemail”) in new stack
– <PJSIP/Telekom_in-00000006> Playing ‘vm-intro.g722’ (language ‘en’)
– <PJSIP/Telekom_in-00000006> Playing ‘beep.g722’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/voicemail/29/tmp/sUva5X format: wav, 0x75b0e0ec
[Feb 6 09:25:52] WARNING[25311][C-00000007]: app.c:1638 __ast_play_and_record: No audio available on PJSIP/Telekom_in-00000006??
– User hung up
== Parsing ‘/var/spool/asterisk/voicemail/voicemail/29/INBOX/msg0004.txt’: Found
== Spawn extension (Telekom_in, 022528301470, 2) exited non-zero on ‘PJSIP/Telekom_in-00000006’

A retry in debug mode showed:

Feb 6 10:24:32] WARNING[25996][C-00000002]: app.c:1638 __ast_play_and_record: No audio available on PJSIP/Telekom_in-00000001??
– User hung up
== Parsing ‘/var/spool/asterisk/voicemail/voicemail/11/INBOX/msg0013.txt’: Found
== Spawn extension (Telekom_in, 022528301471, 2) exited non-zero on ‘PJSIP/Telekom_in-00000001’

No audio available?

Please advise what to do.

Regards,

Joerg

You will need to provide the output of “pjsip set logger on” and “rtp set debug on” for a call that does not work. It may be that they are not sending media or if you are behind NAT that it is getting blocked.

Hello Joshua and thanks again for your answer.

First of all I have to apologize for bothering you again and again with Newbie questions.

By testing and torturing my spouse with my testing I found out that this behaviour only happens when no telephone is registered (as I tend to switch off my VoIP phones if no one’s in the house).

Do you want me to attach the logfile in text format?

Best regards to Canada,

Joerg

If you’d like some insight into what may be the cause then the log info needs to be available somehow.

Is there any way I can upload such a big file?
I plain text it’s not possible and as attachment only pictures are accepted.

You can use pastebin.com and provide a link.

http://pastebin.com/xh44Hnc7

Thanks!

We are sending both an answer and media to them, but they are not acknowledging the answer and not sending us media. I’d look at the network level to make sure their response is not getting dropped by a firewall.

If it would be a firewall it would drop all the communication events.
But if there is an active endpoint there’ll be no loss auf audio.
If the endpoint is not active and there is no ringing (because the endpoint could not be found) only then there’s a loss auf audio…

This doesn’t sound like a firewall drop to me…

Well, the other side is not sending media and it is not responding to our 200 OK. Eliminating the firewall eliminates another part of the equation if one is present. Otherwise you’ll need to talk to your provider as everything looks correct from our side.

Eliminated firewall.

Without success… Still no audio

Firewalls can create dynamic rules, so it is possible that one is being created and then expiring.

I deleted all fw rules, rebooted the router and still no success

Good evening everyone,

do I need to forward all RTP ports to the Asterisk server?

I disabled my firewall and used port forwarding in one try and no port forwarding on another test (I rebooted the router in between).

  • I have on the first call from outside no voice output on the inside phone but output on the outside
  • After one more or less successful call on the next calls I can accpept the call on the inside phone but the caller still has the calling signal.

[Feb 7 20:54:39] WARNING[3836][C-00000001]: app_dial.c:2530 dial_exec_full: Unable to create channel of type ‘SCCP’ (cause 44 - Requested channel not available)
– Called PJSIP/22
– PJSIP/22-00000001 is ringing
– PJSIP/22-00000001 answered PJSIP/Telekom_in-00000000
– Channel PJSIP/22-00000001 joined ‘simple_bridge’ basic-bridge <63d9fea4-4156-4152-9798-6aa880390ffb>
– Channel PJSIP/Telekom_in-00000000 joined ‘simple_bridge’ basic-bridge <63d9fea4-4156-4152-9798-6aa880390ffb>
> Bridge 63d9fea4-4156-4152-9798-6aa880390ffb: switching from simple_bridge technology to native_rtp
> Remotely bridged ‘PJSIP/Telekom_in-00000000’ and ‘PJSIP/22-00000001’ - media will flow directly between them
> Remotely bridged ‘PJSIP/Telekom_in-00000000’ and ‘PJSIP/22-00000001’ - media will flow directly between them
> 0x75d21378 – Probation passed - setting RTP source address to 192.168.178.57:5008
> 0x75d19600 – Probation passed - setting RTP source address to 217.0.7.7:41110
– Channel PJSIP/Telekom_in-00000000 left ‘native_rtp’ basic-bridge <63d9fea4-4156-4152-9798-6aa880390ffb>
== Spawn extension (Telekom_in, 022528301471, 1) exited non-zero on ‘PJSIP/Telekom_in-00000000’
– Channel PJSIP/22-00000001 left ‘native_rtp’ basic-bridge <63d9fea4-4156-4152-9798-6aa880390ffb>
– Executing [022528301471@Telekom_in:1] Dial(“PJSIP/Telekom_in-00000002”, “PJSIP/22&SCCP/11,30”) in new stack
> SCCP: sccp_requestChannel returned Line 11 not currently registered -> Try again later

[Feb 7 20:55:40] WARNING[3844][C-00000002]: app_dial.c:2530 dial_exec_full: Unable to create channel of type ‘SCCP’ (cause 44 - Requested channel not available)
– Called PJSIP/22
– PJSIP/22-00000003 is ringing
– PJSIP/22-00000003 answered PJSIP/Telekom_in-00000002
– Channel PJSIP/22-00000003 joined ‘simple_bridge’ basic-bridge <5d53b3c0-a7b8-4405-9977-ea1adfcb504d>
– Channel PJSIP/Telekom_in-00000002 joined ‘simple_bridge’ basic-bridge <5d53b3c0-a7b8-4405-9977-ea1adfcb504d>
> Bridge 5d53b3c0-a7b8-4405-9977-ea1adfcb504d: switching from simple_bridge technology to native_rtp
> Remotely bridged ‘PJSIP/Telekom_in-00000002’ and ‘PJSIP/22-00000003’ - media will flow directly between them
> Remotely bridged ‘PJSIP/Telekom_in-00000002’ and ‘PJSIP/22-00000003’ - media will flow directly between them
> 0x75d296a8 – Probation passed - setting RTP source address to 192.168.178.57:5014
– Contact 20/sip:20@192.168.178.57:5070 is now Unknown. RTT: 0.000 msec
– Contact 21/sip:21@192.168.178.57:5070 is now Unknown. RTT: 0.000 msec
– Channel PJSIP/22-00000003 left ‘native_rtp’ basic-bridge <5d53b3c0-a7b8-4405-9977-ea1adfcb504d>
– Channel PJSIP/Telekom_in-00000002 left ‘native_rtp’ basic-bridge <5d53b3c0-a7b8-4405-9977-ea1adfcb504d>
== Spawn extension (Telekom_in, 022528301471, 1) exited non-zero on ‘PJSIP/Telekom_in-00000002’
– Contact 22/sip:22@192.168.178.57:5070 is now Unknown. RTT: 0.000 msec
– Contact 23/sip:23@192.168.178.57:5070 is now Unknown. RTT: 0.000 msec

Please advise how to solve the problem.

Do you need another debug log?

What is the Asterisk configuration for pjsip.conf?

Sorry, please explain… I’m not sure what you would like to know…

What is the configuration present in the pjsip.conf file, without passwords?

[global]
type=global
user_agent=LasRamblas
endpoint_identifier_order=ip,username
;default_from_user=012345662008

[transport-udp]
type=transport
protocol=udp
bind=0.0.0.0
local_net=192.168.178.0/24
local_net=10.10.10.0/27
external_media_address=vpn.test.de
external_signaling_address=vpn.test.de

[transport-tcp]
type=transport
protocol=tcp
bind=0.0.0.0
local_net=192.168.178.0/24
local_net=10.10.10.0/27

[acl]
type=acl
deny=0.0.0.0/0.0.0.0
; Telekom und sipgate
permit=217.0.0.0/13
permit=217.10.64.0/20
permit=217.116.112.0/20
permit=212.9.32.0/19
; eigenes LAN
permit=192.168.178.0/24
permit=10.10.10.0/27

;****************************************************
; externe SIP-Accounts
;****************************************************

[01_Telekom_012345662008]
type=registration
transport=transport-udp
outbound_auth=01_Telekom_012345662008_auth
server_uri=sip:tel.t-online.de
client_uri=sip:+4912345662008@tel.t-online.de
contact_user=012345662008
retry_interval=60
forbidden_retry_interval=300
expiration=480
auth_rejection_permanent=false

[01_Telekom_012345662008_auth]
type=auth
auth_type=userpass
password=12340001@t-online.de
username=012345662008
realm=tel.t-online.de

[01_Telekom_012345662008_out]
type=endpoint
transport=transport-udp
context=unspecified
disallow=all
allow=g722
allow=alaw
outbound_auth=01_Telekom_012345662008_auth
aors=01_Telekom_0123456620080_out
callerid=012345662008
from_user=012345662008
from_domain=tel.t-online.de
timers=no
rtp_symmetric=yes

[01_Telekom__012345662008_out]
type=aor
contact=sip:+4912345662008@tel.t-online.de

[Telekom_in]
type=endpoint
transport=transport-udp
context=Telekom_in
disallow=all
allow=g722
allow=alaw
outbound_auth=01_Telekom_012345662008_auth

[Telekom_in]
type=identify
endpoint=Telekom_in
match=217.0.0.0/13

;****************************************************

[02_Telekom_012345601470]
type=registration
transport=transport-udp
outbound_auth=02_Telekom_012345601470_auth
server_uri=sip:tel.t-online.de
client_uri=sip:+4912345601470@tel.t-online.de
contact_user=012345601470
retry_interval=60
forbidden_retry_interval=300
expiration=480
auth_rejection_permanent=false

[02_Telekom_012345601470_auth]
type=auth
auth_type=userpass
password=12340001@t-online.de
username=012345601470
realm=tel.t-online.de

[02_Telekom_012345601470_out]
type=endpoint
transport=transport-udp
context=unspecified
disallow=all
allow=g722
allow=alaw
outbound_auth=02_Telekom_012345601470_auth
aors=02_Telekom_012345601470_out
callerid=012345601470
from_user=012345601470
from_domain=tel.t-online.de
timers=no
rtp_symmetric=yes

[02_Telekom_012345601470_out]
type=aor
contact=sip:+4912345601470@tel.t-online.de

;****************************************************

[03_Telekom_012345601471]
type=registration
transport=transport-udp
outbound_auth=03_Telekom_012345601471_auth
server_uri=sip:tel.t-online.de
client_uri=sip:+4912345601471@tel.t-online.de
contact_user=012345601471
retry_interval=60
forbidden_retry_interval=300
expiration=480
auth_rejection_permanent=false

[03_Telekom_012345601471_auth]
type=auth
auth_type=userpass
password=12340001@t-online.de
username=012345601471
realm=tel.t-online.de

[03_Telekom_012345601471_out]
type=endpoint
transport=transport-udp
context=unspecified
disallow=all
allow=g722
allow=alaw
outbound_auth=03_Telekom_012345601471_auth
aors=03_Telekom_012345601471_out
callerid=012345601471
from_user=012345601471
from_domain=tel.t-online.de
timers=no
rtp_symmetric=yes

[03_Telekom_012345601471_out]
type=aor
contact=sip:+4912345601471@tel.t-online.de

;****************************************************

[04_sipgate_Joerg_012345669796]
type=registration
retry_interval=20
max_retries=10
contact_user=1234567
expiration=120
transport=transport-udp
outbound_auth=04_sipgate_Joerg_auth
client_uri=sip:1234567@sipgate.de:5060
server_uri=sip:sipgate.de:5060

[04_sipgate_Joerg_auth]
type=auth
username=1234567
password=ABCDEFG

[04_sipgate_Joerg_aor]
type=aor
contact=sip:1234567@sipgate.de

[04_sipgate_Joerg_identity]
type=identify
endpoint=04_sipgate_Joerg
match=sipgate.de

[04_sipgate_Joerg]
type=endpoint
context=04_sipgate_Joerg-in
dtmf_mode=rfc4733
disallow=all
allow=alaw
rtp_symmetric=yes
force_rport=yes
rewrite_contact=yes
timers=yes
from_user=1234567
from_domain=sipgate.de
language=en
outbound_auth=04_sipgate_Joerg_auth
aors=04_sipgate_Joerg_aor

;****************************************************
; interne SIP-Accounts
;****************************************************

[20]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=20-auth
aors=20
mailboxes=20

[20-auth]
type=auth
auth_type=userpass
password=1234
username=20
realm=domain.local

[20]
type=aor
max_contacts=1
remove_existing=true

[20]
type=identify
endpoint=20
;match=192.168.178.57

;****************************************************

[21]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=21-auth
aors=21
mailboxes=21

[21-auth]
type=auth
auth_type=userpass
password=1234
username=21
realm=domain.local

[21]
type=aor
max_contacts=1
remove_existing=true

;****************************************************

[22]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=22-auth
aors=22
mailboxes=22

[22-auth]
type=auth
auth_type=userpass
password=1234
username=22
realm=domain.local

[22]
type=aor
max_contacts=1
remove_existing=true

;****************************************************

[23]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=23-auth
aors=23
mailboxes=23

[23-auth]
type=auth
auth_type=userpass
password=1234
username=23
realm=domain.local

[23]
type=aor
max_contacts=1
remove_existing=true

;****************************************************

[30]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=30-auth
aors=30
mailboxes=30

[30-auth]
type=auth
auth_type=userpass
password=1234
username=30
realm=domain.local

[30]
type=aor
max_contacts=1
remove_existing=true

;****************************************************

[31]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=31-auth
aors=31
mailboxes=31

[31-auth]
type=auth
auth_type=userpass
password=5678
username=31
realm=domain.local

[31]
type=aor
max_contacts=1
remove_existing=true

;****************************************************

[32]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=32-auth
aors=32
mailboxes=32

[32-auth]
type=auth
auth_type=userpass
password=1234
username=32
realm=domain.local

[32]
type=aor
max_contacts=1
remove_existing=true

;****************************************************

[98]
type=endpoint
transport=transport-udp
context=internalsip
disallow=all
allow=g722
allow=alaw
auth=98-auth
aors=98
mailboxes=98

[98-auth]
type=auth
auth_type=userpass
password=123456
username=98
realm=domain.local

[98]
type=aor
max_contacts=1
remove_existing=true

[98]
type=identify
endpoint=98
match=192.168.178.0/27
match=10.10.10.0/27

I would suggest using an explicit IP address for the external_media_address and external_signaling_address options. You will also need to ensure the external RTP ports (10000-20000 by default) are forwarded to Asterisk. You will also want to set the direct_media option to no on any endpoints which are behind NAT.

Good morning and thanks.

As I do have a dynamic external IP I can’t use a stitc IP for external_media_address and external_signaling_address. OR is there a function/variable within Asterisk to determine and use the external IP?
Just to make sure I forwarded ports 10000 to 50000 to Asterisk.
I’m using a Cisco 881 router an this is the forwarding part of my config

ip nat pool PortFwd-VoIP 192.168.178.207 192.168.178.207 netmask 255.255.255.0 type rotary
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static tcp 192.168.178.207 5060 interface Dialer1 5060
ip nat inside source static udp 192.168.178.207 5060 interface Dialer1 5060
ip nat inside destination list 110 pool PortFwd-VoIP
!
access-list 101 permit ip 192.168.178.0 0.0.0.255 any
access-list 110 permit udp any any range 10000 51000
access-list 111 permit udp any eq 5060 any
access-list 111 permit udp any range 10000 51000 any
access-list 111 deny ip any any log
!
interface Dialer1
ip access-group 111 in

Setting direct_media option to no I’ll try as soon as I’m able to test.

Regards,

Joerg