Asterisk-IMS Server interconnect

Hi Friends,

I am Dharmesh from India. I have setup a SIP trunk to IMS server for outgoing calls. Registration with IMS server works properly. When I make calls, in INVITE message, it takes SIP URI by default. Is there any way by which I can enable TEL URI in outgoing INVITE message. I am using asterisk 13.1.0~dfsg-1.1ubuntu4 on Ubuntu 16.04LTS server. Asterisk installed with apt-get.

Below is my sip.conf trunk configuration…Thanks in advance

insecure = invite
dtmfmode = rfc2833
usereqphone = yes

The IMS server is broken if it does not support SIP: URIs, as they are the only mandatory ones in the specification.

chan_sip does not allow this. I’m not sure about chan_pjsip.

You have conflicting settings for insecure. The second one will actually apply and is normally sufficient.

The chan_pjsip module has no support for tel: URIs and has explicit code to prevent their use, so as to avoid problems elsewhere (where things expect a SIP URI for example).