Asterisk connection to Cisco CUBE


#1

Our ISP is using a Cisco CUBE to deliver a SIP trunk to us from another provider further upstream. When they provided the connection information, there is no username or password, only an IP address. I pointed out that I didn’t know how to configure the registration in our sip.conf file and the ISP said that the CUBE didn’t require a registration.

I’ve added the following to our sip.conf and extension.conf file and when I try to place an outside call, it really looks like it’s trying but just can’t communicate with the SIP trunk. It makes me think that Asterisk really doesn’t like CUBE’s.

sip.conf:

;register => <our phone number>@<our ISP's CUBE Server Address>

[ext-sip-provider]
type=friend
context=from-voip-provider
username=<our phone number>
fromuser=<our phone number>
secret=
host=<our ISP's CUBE Server Address>
qualify=yes
insecure=port,invite
nat=yes

extension.conf

exten => _X.,1,Dial(SIP/${EXTEN}@ext-sip-provider)

I originally tried registering with the CUBE but it never seemed to answer, and after being told by the ISP that you don’t need to register with the cube, I commented that line out.

The asterisk sever is on a static NAT and is running great internally as a fancy intercom system, but obviously I need to get it hooked up to the outside.

Any clues? As I said earlier, I’m think Asterisk -> CUBE is just not working, though I hope I’m wrong.

— Dave


#2

What is the NAT configuration in the general section?

secret=
insecure=port,invite

doesn’t make sense. insecure=invite stops Asterisk trying to authenticate incoming calls, but it will only try to do so if it has a secret.

insecure=port

applies to certain complicated NAT situations and SHOULD NOT be used unless they actually apply. The reason is given by the name of this option!


#3

I have some new information regarding my problems connecting to a Cisco CUBE at my ISP.

FIrst, as a test of my general Asterisk configuration, I registered an account with SIP2SIP and within about 5 minutes was able to place calls to their music line and it worked fine. Other than incorporating their specific information, I had to make no changes to my general configuration. It just worked and it works from every phone in the system that I have tried. This makes me feel better about the general configuration, but worse about the chances of getting connected to my ISP’s Cisco CUBE.

Second, my ISP gave me a sample of a sip.conf file that they think will work. It is as follows:

[my-isp]
type=peer
context=incoming
host=<isp-cisco-cube-address>
disallow=all
allow=ulaw
nat=no
canreinvite=yes
qualify=yes

I made this change and restarted Asterisk but still no happiness. I setup wireshark on the connection to them and watched the exchange between the two. I am sending them OPTIONS packets but they never reply. As you may recall from my first posting, the ISP says that I don’t have to register with them. I think that they are probably mistaken about that but I don’t know for sure. To test my theory, I added a register line in the sip.conf file for them but with bogus credentials since they don’t supply credentials. Again, I watch the wireshark output and this time I see both REGISTER and OPTIONS packets but again, no reply from the ISP.

Based on the ease that I had connecting to another provider and the complete silence in the packet sniffing, I think the Cisco CUBE at my ISP is just not responding to me. Can anyone give me a clue as to where to go next? Has anyone gotten an Asterisk to talk to a Cisco CUBE and if so, what sort of configuration changes need to be made (on either end)?

I realize this is quickly becoming a CIsco CUBE question and not an Asterisk one but I do appreciate any suggestions. Frankly, if it weren’t for the existing relationship with the ISP, I’d just move to another provider.

— Dave


#4

Are you on a real IP address? Your setup assumes this.


#5

AFAIK The ITSP is the regsitrar and the CUBE is the Proxy.
That way the CUBE rewrites the ITSP’s sip packets for the local network. Media is handled by an RTP proxy.

I’m getting hold of a 2900 CUBE system in the next week or so and I’ll have a play and get back to you if I work something out.

Cheers
Chris