Asterisk beta 1.2 and spandsp


#1

Sorry if this is the wrong place for this post, but I am not an asterisk developer.

I have been using the spandsp module with asterisk 1.0 and 1.1 for some time, but I am having some issues using the rxfax application with the beta release of 1.2, but I do already love the real time functionality so thank you for that!

I have downloaded the latest spandsp0.0.2pre20 and used the app_rxfax.c, app_txfax.c, and apps_makefile.patch from the 1.1 subdir from the spandsp ftp site. I am able to cofigure build and install both spandsp and asterisk with the patched application file correctly, but when I try to load the rxfax application I get the following error:

localhost*CLI> load app_rxfax.so
Unable to load module app_rxfax.so
Sep 6 09:23:37 WARNING[26278]: loader.c:314 __load_resource: /usr/lib/asterisk/modules/app_rxfax.so: undefined symbol: fax_release

So it obviously finds the .so module, but is having trouble with a variable it refers to somewhere. Is this a compatibility issue with 1.2 in how the core of * was changed, or user error on my part?

Please let me know if you have seen this, or if I can be of any help in testing or resolving it.


#2

i am having the same issue with * CVS HEAD and spandsp .2pre21! I’m going to drop this post into the Users forum so hopefully it will get some attentions!