ASTERISK and TCP port 5060?


I have a problem. My asterisk works with Grandstream phones without problems, but now i have TANDBERG devices. But there is a problem that my Asterisk server listening on 5060/UDP and Tandberg wants to register over 5060/TCP. There is not any possibilty to switch it to UDP.

Is there any change to switch Asterisk to 5060/TCP too?



There shouldn’t be a problem - The SIP phone should register on port 5060 if Asterisk listens on that port, which is the default. I think your problem is maybe the setup on the TANDBERG. Do you see on the console that the TANDBERG tries to register?

afaik Asterisk only uses UDP.


Yes, I see on Tandberg
in first time: Registering - using SIP server IP:5060 (it’s OK)
and then: Failed to register - Unable to TCP-connect to SIP Server

I tried this morning to set SIP server on TANDBERG to address of my notebook where i have Ethereal and I see TANDBERG really tried to connect over TCP to port 5060 and none UDP.

It looks like different implementation of SIP on Tandberg and Asterisk.

There is no possibility to change TANDBERG for UDP communication and there is no chance to change Asterisk implementation to listening on TCP.

I had the same problem with the tandberg TCP/UDP problem.

The tandberg system (MXP platform only 3.0 minimum firmware) can be switched between TCP and UDP.

you need to open a telnet session with your tandberg.

using the telnet api, type:

xconfig SIP Transport Default: UDP

response should be : OK

to check your settings type:

xconfig SIP

It should respond: (the last line should read UDP)
*c xConfiguration SIP Mode: On

*c xConfiguration SIP Server Discovery: Manual

*c xConfiguration SIP Server Address: “”

*c xConfiguration SIP Server Type: Auto

*c xConfiguration SIP Authentication UserName: “213”

*c xConfiguration SIP Transport Default: UDP

Type “boot” to reboot and you should be all set.


hi there, I am having an similar issue, I have a tandberg T150 phone and I am trying to connect to an asteriskNow implementation (running on VMWare) I tried the config that jchuchla showed above (all of which I can do right on the phone) and I am getting a “Failed to register: Using SIP Server 172.16.***.***”, do I need to register the phone’s mac address with the system?..Oh I have 2 x-lite softphones funtioning with the system so I know it is working!

Any help would be great…

Cheers Tim