PJSIP unable to use TCP

Hi,

I am trying to create a sip trunk between 2 asterisk and they speak TCP/5060 but it is impossible, they only try UDP.

[tcp]
type = transport
protocol = tcp
bind = 0.0.0.0:5060
allow_reload = no
local_net = 192.168.10.0/24
local_net = 10.4.0.0/27
local_net = 10.4.1.0/27
local_net = 10.4.100.0/28

[transport-udp]
type = transport
protocol = udp
bind = 0.0.0.0:5060
local_net = 192.168.10.0/24
local_net = 10.4.0.0/27
local_net = 10.4.1.0/27
local_net = 10.4.100.0/28
allow_reload = no

; PBX02_LAN
[PBX02-registration]
type = registration
outbound_auth = PBX02-auth
server_uri = sip:192.168.11.5:5060
client_uri = sip:PBX01-aor@192.168.11.5:5060
retry_interval = 60
auth_rejection_permanent = false

[PBX02-auth](auth-userpass)
username = superuser
password = supersecret

[PBX02-aor]
type = aor
max_contacts = 10
remove_existing = yes
contact = sip:192.168.11.5\;transport=tcp

[PBX02]
type = endpoint
context = pbx01
allow = !all,ulaw,alaw,g722,vp8,h264
auth = PBX02-auth
aors = PBX02-aor
direct_media = no
transport = tcp
;media_encryption = sdes

[PBX02-identify]
type = identify
match = 192.168.11.5
endpoint = PBX02

Capture:

2022/06/15 23:53:25.137264 10.4.100.5:5060 -> 192.168.11.5:5060
REGISTER sip:192.168.11.5:5060 SIP/2.0
Via: SIP/2.0/UDP 212.183.224.62:5060;rport;branch=z9hG4bKPj59fa3945-ad7d-461b-82-fd197b78c8bf
From: <sip:PBX01-aor@192.168.11.5>;tag=141e5ff0-5336-42b5-9d6c-837e930f2394
To: <sip:PBX01-aor@192.168.11.5>
Call-ID: a029b4a5-d67c-4df9-81e4-f86e4fe7a149
CSeq: 43198 REGISTER
Contact: <sip:s@10.4.100.5:5060>
Expires: 3600                                                                   Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL,
DATE, PRACK, MESSAGE, REFER
Max-Forwards: 70
User-Agent: Asterisk PBX 18.11.0                                                Content-Length:  0

Regards,

You haven’t specified a transport for the type=registration section. Registration is completely independent of end points.

Also, if the arrangement is symmetric, you shouldn’t need registrations at all.

Thanks!!