Asterisk and Gateway Planet vip480 F0 , extension problem

Hello

I use you program Asterisk and everything work fine but is a one little problem but for me is large.
I connect to Astersik Gateway VIP 480 F0 as sip client on the number 200. Something like this:

[200]
type=friend
regexten=200
callerid=“wyjcie” <200>
host=dynamic
username = 200
register => 200:9012@192.168.10.254
;disallow=all
allow=gsm
allow=ulaw
allow=alaw

Work fine when I call to 200 after I wait for the signal and when signal is I call to outside like example: 0227825122

but !!!

I want call like 0227825122 and I try extensions.conf set a:
exten => _XXXXXXXXXX,1,Dial(SIP/200/${EXTEN})

AND not work !!!
How set extension to call like this ???
please help.

Sorry for my English
Best Regards
Grzegorz

Perhaps you have to strip the first 3 digits ? Try

exten => _XXXXXXXXXX,1,Dial(SIP/200/${EXTEN:3}) 

Cheers.

Marco Bruni

No Is still wrong :

console tells me :

Spawn extension (default, 200, 1) exited non-zero on ‘SIP/czelusc-081f11b8’
– Executing [2000227825122@default:1] Dial(“SIP/czelusc-081f11b8”, “SIP/200/0227825122”) in new stack
– Called 200/0227825122
– SIP/200-081f5520 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)
== Auto fallthrough, channel ‘SIP/czelusc-081f11b8’ status is ‘CONGESTION’

SIP200 is a gateway Planet VIP-480.

Check if the gateway has an “immediate” dial mode, this means that it directly dials the digit received from sip instead of giving you a dial tone and then waiting for the digits to dial.

Hope this helps.

Cheers.

Marco Bruni

I was send to planet a question are this gateway have immediate dial mode I
will write when they answer me.

Thanks for Help

Best Regards
Grzegorz

Yes Gateway VIP-480F0 have this immediate dial mode and is enable.

I was tried something else like:

exten => _XXXXXXXXXX,1,Dial(SIP/200,2,D(${EXTEN}))

But still not work

Maybe you have any else idea for that ???

I have problem register vip-480 to asterisknow 3.1 version newest ? can you help me?