Asterisk 13 not playing audio


I installed Asterisk 13 on Debian 9, and I tried in several different ways to play an audio file and I call, asterisk answers but it doesn’t play the file. Here is my extensions.conf:

exten => s,1,NoOp(IVR1)
same => n,Answer
same => n,Read(/var/lib/asterisk/sounds/custom/welcome)
same => n,WaitExten(5)

exten => 6598,1,Goto(ivr1,s,1)

Asterisk shows:

-- Executing [6598@ivr1:1] Goto("SIP/user-cc-0000001c", "ivr1,s,1") in new stack
-- Goto (ivr1,s,1)
-- Executing [s@ivr1:1] NoOp("SIP/user-cc-0000001c", "IVR1") in new stack
-- Executing [s@ivr1:2] Answer("SIP/user-cc-0000001c", "") in new stack
-- Executing [s@ivr1:3] Read("SIP/user-cc-0000001c", "/var/lib/asterisk/sounds/custom/welcome") in new stack
-- User disconnected

I tried with 2 different SIP Clients and the sounds doesn’t play. I tried with different codecs and still doesn’t play.

I also executed

iptables -I INPUT -m state --state NEW -m udp -p udp --dport 10000:20000 -j ACCEPT

Any ideas what could it be the problem?


start by doing and **rtp set debug on** to check it there is media traffic

The first parameter (the name of the variable to be set, is missing, or you used Read when you meant Playback.