Asterisk 13 Fax Issue

Hi, I am trying to send FAX using the Asterisk application. However, I am facing the following issue.

I tried fixing it by adding “f” option in the SendFAX() function in extensions.conf file. But it is not working in some fax machines. Please help me to resolve this.

Are you using “app_fax” or “res_fax_spandsp”?
Normally, you would want to use “res_fax_spandsp” and blacklist the “app_fax” module in modules.conf.

1 Like

Hi, Please find this screenshot. We are using res_fax & res_fax_spandsp and there is no “app_fax” loaded

Can you try blacklisting and unloading “res_fax.so” (if possible, otherwise you have to restart) and try again?
AFAIK “res_fax” is provided by Digium and needs to be licensed to be fully used.

1 Like

The res_fax module is not licensed and is open source, it provides the common applications and interface for faxing.

1 Like

Hi @lordgurke. I tried unloading the res_fax.so by adding “noload => res_fax.so” in module.conf. However, after this asterisk is not running properly. Also, no fax received after this change.

Hi @jcolp, Is there any solution where we can make fax work reliably without adding “f” option in that SendFAX() function?

When FAX is sent, sometimes it does not print the FAX and we get the following error " Auto fallthrough, channel ‘PJSIP/fax_ext-00000000’ status ‘UKNOWN’ " Any Idea why I am getting this?

I only commented in regards to the res_fax licensing, I don’t currently have anything else to add to this thread.

1 Like

I’ve never used fax on Asterisk, so can’t help you on your fax problem, but auto fallthrough is not an error.

1 Like

does this involve local chanells?