Asterisk 13.15.0, WebRTC SIPml5 and Chrome 57 no sound


#1

The following error is shown in the browser console

DOMException: Failed to set remote answer sdp: Session error code: ERROR_CONTENT.
Session error description: rtcpMuxPolicy is ‘require’, but media description does not contain ‘a=rtcp-mux’…

So I upgraded to Doubango SIPml5 v2.1.3 as per

http://stackoverflow.com/questions/42688499/sipml5-negotiate-rtcpmuxpolicy

To no avail, still no sound flowing even though rtcpMuxPolicy:“negotiate” is set.
FireFox works just fine.

WebRTC Chrome 57.0.2987.133 (64-bit), no sound in IVR using Doubango SIPml5 v2.1.3 Asterisk 13.15.0.
WebRTC FireFox ESR 52.0(64-bit), sound OK in IVR using Doubango SIPml5 v2.1.3 Asterisk 13.15.0.
Doubango SIPml5 v2.1.3 sets rtcpMuxPolicy:“negotiate”, so that should have fixed the problem, but still no sound in Chrome.

Any sugestions ?


#2

This can be fixed in Asterisk by enabling RTCP MUX. It’s available as of 13.15.0:

res_rtp_asterisk:
 - The RTP layer of Asterisk now has support for RFC 5761: "Multiplexing RTP
   Data and Control Packets on a Single Port." For the PJSIP channel driver,
   chan_pjsip, you can set "rtcp_mux = yes" on a PJSIP endpoint in pjsip.conf
   to enable the feature. For chan_sip you can set "rtcp_mux = yes" either
   globally or on a per-peer basis in sip.conf.

#3

Thx again J.
I added the column in my realtime table and everything works just fine.

Only remark, the change is not in the pjsip.conf.sample, so that might be something for the future.


#4

The sample configuration file does not have the complete option documentation, there’s a few things missing from there. We’ll add a link to the wiki in the future which is automatically kept up to date.


#5

Hello, how do I apply this to 13.15.0. I’ve tried everything to no avail.

Tried setting up version 14 which doesn’t work and really struggling as need this system to work.

Hope someone can help


#6

The RTCP MUX feature itself is available in 13.15.0 on both chan_sip and chan_pjsip. It can be enabled by setting “rtcp_mux” to yes on either a PJSIP endpoint or SIP peer. If that isn’t working then you’ll need to be more specific about what exactly is happening and what you are seeing.


#7

Hi, thanks for this. I tried adding it to the sip.config file rtcp_mux=yes is this not the right place? Sorry only been playing with asterisk for the last day or so


#8

Yes, but it has to be put in a SIP peer entry.


#9

Under here?


#10

I assume so. I don’t use FreePBX and don’t have experience in it. I also don’t know if that is the peer being used for your call.


#11

Thats the external handler for all my calls to the outside world. Unfortunately it didn’t seem to make any difference. As you can see the same thing is being blocked in google still.


#12

You would need to set it on the peer used between Asterisk and the device. Not on an entry that is used for a VoIP provider.


#13

Very interesting, added that and it now works so accepts the call, just no sound on either end. Nearly there, thank you so much for your help. Its a great system :slight_smile: