Asterisk WebRTC + SipML5 no audio in Chrome

Hi All,

I have a demo asterisk setup running in AWS Ec2 instance. We are using Asterisk 13.15.0 with WebRTC and SIpML5, but unfortunately, there’s no audio when calling from Chrome 58. Audio is fine when we try calling from Firefox and Zoiper. As per the recent update in the community I’ve updated the SipML5 to the latest, but still no luck. Below are my settings, can someone please help me to resolve the issue.

sip.conf

[general]
externaddr= 52.247.186.5 ; Public ElasticIP
media_address= 52.247.186.5 ; Public ElasticIP
localnet= 172.31.0.0/255.255.0.0 ; Internal network and mask
realm=52.247.186.5 ; Used for authentication
transport=udp,wss,ws,tls
websocket_enabled = true
tlsenable=yes
tlsbindaddr=0.0.0.0
tlscertfile=/etc/ssl/certs/domain.pem
tlsprivatekey=/etc/ssl/private/domain.com.key
tlscafile=/etc/ssl/crt/domain.com-ca.crt
tlscipher=ALL
tlsclientmethod=tlsv1
nat=force_rport,comedia
icesupport = yes
rtcp_mux = yes

[6000]
context=wrtc
host=dynamic
type=peer
encryption=yes
avpf=yes
icesupport=yes
directmedia=no
disallow=all
allow=ulaw
transport=ws,wss,udp,tls
force_avp=yes
nat=force_rport,comedia
secret=60000
dtlsenable=yes
dtlsverify=no
dtlscertfile=/etc/ssl/certs/domain.pem
dtlsprivatekey=/etc/ssl/private/domain.com.key
dtlscafile=/etc/ssl/crt/domain.com-ca.crt
dtlssetup=actpass
videosupport=no
rtcp_mux = yes

[6001]
context=wrtc
host=dynamic
type=peer
encryption=yes
avpf=yes
icesupport=yes
directmedia=no
disallow=all
allow=ulaw
transport=ws,wss,udp,tls
force_avp=yes
nat=force_rport,comedia
secret=6001
dtlsenable=yes
dtlsverify=no
dtlscertfile=/etc/ssl/certs/domain.com.pem
dtlsprivatekey=/etc/ssl/private/domain.com.key
dtlscafile=/etc/ssl/crt/domain.com-ca.crt
dtlssetup=actpass
videosupport=no
rtcp_mux = yes

;extension to use on softphones
[6002]
host=dynamic
secret=6002
context=wrtc
type=peer
transport=ws,wss,udp,tls
directmedia=no
disallow=all
allow=all

rtp.conf

[general]
rtpstart=10000
rtpend=20000
icesupport=yes
stunaddr:19302=stun.l.google.com

http.conf

[general]
servername=domain.com
enabled=yes
bindaddr=0.0.0.0
tlsenable=yes
tlsbindaddr=0.0.0.0:8089
tlscertfile=/etc/ssl/certs/domain.com.pem
tlsprivatekey=/etc/ssl/private/domain.com.key

extensions.conf

[wrtc]
exten => _X.,1,Dial(SIP/${EXTEN})
exten => _X.,n,Answer()
exten => _X.,n,Hangup()

Sip debug can be found here https://pastebin.com/ZNXEgsu5

Thank you

Have you find a solution?, it is crazy, but i am trying the same thing, and i can’t get audio at all,
cant get it even through zoiper to zoiper…