Asterisk 13.12.1 Broken Opus Transcoding with useinbandfec=1?

A caller using Linphone PC or iOS with Opus results in the receiver hearing silence if transcoding is required. A direct Opus to Opus call works fine. Setting useinbandfec=0 on the PC version fixes the issue. The iOS version does not have the ability to disable it.

Is this a compatibility issue of some sort or does Asterisk improperly handle FEC?

1 Like

This is an issue which should be resolved in the next release of codec_opus.