Asterisk 11 and MySql Connectivity Problem in Realtime


I installed and configured Asterisk 11 successfully. I installed MySql through apt-get and working perfectly. But, when I am trying to connect from Asterisk to MySql in real time, I am getting the below error message on Asterisk CLI:

WARNING[3027]: config.c:2429 find_engine: Realtime mapping for ‘sippeers’ found to engine ‘mysql’, but the engine is not available

I followed the below link: … connection:

Please note that as I noticed that we no need to install Asterisk-addons again with Asterisk 11 or after Asterisk 1.8 versions.

I have done lot of research on this issue and gone through many threads. I tried from the posted threads and below is the output:

Please note that “service mysql status” is showing “mysql start/running, process 967”.

I could not able to find “” file in “/usr/lib/asterisk/modules/”.

When I run “realtime mysql status” on Asterisk CLI, it is saying that “No such command”. I think that this command is removed in Asterisk 11.

When I run “module show” on Asterisk CLI, there is no “” file.

If anybody faced this issue with the latest versions of Asterisk (1.8 onwards), please tell me the resolution.

Please do needful. Thanks in advance.


[quote]I could not able to find “” file in “/usr/lib/asterisk/modules/”.
[/quote] Then go back and compile again asterisk with support for that.


I solved the issue by installing MySQL Client development library :

apt-get install libmysqlclient-dev

Thank you.