Asterisk 11.9 CentOS 6.5 [SOLVED]


I’m trying to build and install Asterisk 11.9 on CentOS 6.5 64-bit. The first time I configured and installed it, I neglected to put the --libdir=/usr/lib64 as one of the configure parameters. Therefore, it put everything in the /usr/lib directory. After running asterisk and getting a missing library error, I realized what I had done. I uninstalled asterisk, did a make dist-clean and started over, this time including the previously mentioned parameter in the configure. But, after installing and then running asterisk, the log file shows that it can’t find any of the modules and so a lot of modules and resources aren’t loading. But they are there in /usr/lib64. The log error messages indicate that it can’t find the module .so files…

[May 13 04:52:03] WARNING[24314] loader.c: Unable to open modules directory '/usr/lib/asterisk/modules'.

[May 13 04:53:25] WARNING[24411] loader.c: Error loading module '': /usr/lib/asterisk/modules/ cannot open shared object file: No such file or directory

The path it’s looking for them in is /usr/lib. I’ve tried rebuilding the, reinstalling several times, but it still tries to look for the libraries in the /usr/lib folder. Any suggestions as to why and how to resolve this problem? I look forward to any replies on this issue. Thanks.


Change the path of the astmoddir in the asterisk.conf file.


Thank you. That worked. I appreciate your response.