Asterisk + meetme audio Latency Grows over time

Hi all

I am using currently CentOs as opertating system and Asterisk® Open Source PBX asterisk and for conferencing now I am using using meetme and pjsua1.8 as sip user agent or sip client on hard phones on local network (private network)
what happens is when any meetme conference is created it works fine with latency 250-300ms for some hour or hour and half after that there is 1-3 seconds of delay in audio

as I was adviced that appkonference is thirdparty contributed application now the same problem is with meet me also. Please guide me whether there is any asterisk configuration that I am missing or any timing related configuration is wrong or missed .
Also let me tell you that pjsua to pjsua sip communication do not have this delay (i.e. one sip agent directly calling another sip agent ) so only when the asterisk is introduced in-between then only this delay gets introduced.
Please guide me to get rid of this problem.

Thanks in advance

I know that confbridge isn’t supported under 1.8, but do you see the same problem there? I ask, because confbridge doesn’t invoke dahdi as a timer. Do you see similar delays with new bridges after Asterisk has been running for 90 minutes, or just a bridge that itself has been active for 90 minutes? New bridges after Asterisk has been running for 90 minutes do not have delay?

What you really want to be testing with Asterisk is the functionality of the confbridge app that appears beginning in Asterisk 10, though you really want to be on Asterisk 11. Confbridge does what MeetMe does, and more, and it’s what people should be using for meet me style confbridges going forward.


I have never mentioned nor used confbridge for my application .
I have tried with meetme() and appkonference in both the cases I observed the problem of delay .
Do you mean to say that the delay problem will be solved by use of confbridge? but in this case I have problem. I am using asterisk 1.8 , which you say doesn’t support confbridge. Again I can not move to asterisk 10 and above at this point of time because my whole application interface changes.

Please advice

Thanks & Regards

I think he is saying that, if you still get the delays in confbridge, someone is likely to be interested in fixing it.

Sorta. I’m saying that there are different timing sources for meetme (dahdi) and confbridge (timerfd) and I’m wondering if there’s a difference in experience with respect to latency.


Let me explain my problem again.
The conference latency grows as time passes.
This I experienced with MeetMe as well as AppKonference
I havent tested with ConfBridge.

Do you think that the problem is related to Conference Module of any of the type as above?

Do you recommend me to use ConfBridge with Asterisk 1.8?


I don’t think anyone can say with certainty. I think you are being asked to use Confbridge to try and eliminate possibilities.

It does seem likely that something in your system has a very inaccurate timing crystal.

One specific thought is that there is an issue with Asterisk that it dosn’t change the timing source ID when the timing source changes. For most phones that isn’t a problem, but it is just possible that your phones react badly when there is a switch between two sources with radically different clock frequencies. You might be able to work round that by finding the device with the wrong frequency, and eliminating it.

Another possible variation is that the phone is trying to slew the timing after such an unannounced timing source change. I don’t know any easy way for you to work round that.

One thing you are probably going to have to do, to progress this, is to capture both incoming and outgoing RTP streams as a PCAP file and analyze them with wire shark. That way, you will be able to work out whether the delay is being introduced within Asterisk. As Asterisk doesn’t normally do latency buffering on SIP, that would be a strong indication of a problem with the conference bridges.


Thanks. This seems to be some hope!
Now, where should I look into the asterisk so that I could see the “bad device”?



If you have a problem device, it will be outside Asterisk.