Asterisk 1.4.29 and static call forwarding = Problem


I have a little Problem with my Asterisk 1.4.29. I used to update from 1.2.X to the latest 1.4.29. The migration went well - everything works fine, but I still have following problem. If an extension tries to setup a static call forwarding (on the phone) to another internal extension. The call is getting redirected - but the caller does not hear a ringing.

Extension 100 (setup a call forward to 101)
Extension 101

Now - if I call 100 - the call is getting forwarded to 101. The phone is ringing and you can esthablish a call. The only Problem is, that the caller of 100 is not getting a “ringing” in his phone. Its quiet untill 101 is taking the call. Strange thing that.

Maybe there is something wrong on my sip.conf ?

[code]Global Settings:

SIP Port: 5060
Videosupport: No
AutoCreatePeer: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Promsic. redir: No
SIP domain support: No
Call to non-local dom.: Yes
URI user is phone no: No
Our auth realm asterisk
Realm. auth: No
Always auth rejects: No
Call limit peers only: No
Direct RTP setup: No
User Agent: Asterisk PBX
MWI checking interval: 10 secs
Reg. context: (not set)
Caller ID: asterisk
From: Domain:
Record SIP history: Off
Call Events: Off
IP ToS SIP: none
IP ToS RTP audio: none
IP ToS RTP video: none
T38 fax pt UDPTL: No
RFC2833 Compensation: No
SIP realtime: Disabled

Global Signalling Settings:

Codecs: 0xc (ulaw|alaw)
Codec Order: ulaw:20,alaw:20
T1 minimum: 100
No premature media: No
Relax DTMF: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: No
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No

Default Settings:

Context: default
Nat: RFC3581
DTMF: rfc2833
Qualify: 0
Use ClientCode: No
Progress inband: Never
Language: de
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: asterisk[/code]


There is no intrinsic call forward capability in Asterisk. It has to be implemented by user or GUI provided dialplan, or by the phone. Which of these applies. If it is user provided, please supply the relevant dialplan. If it is implemented by a GUI, please, at least, identify the GUI.


thanks for your reply. The call forward is setup by its phone. Its a Snom 820 Phone. I also tested it with other Snom phones - same Problem.

The call forward used to work with 1.2.X - after the migration from 1.2.X to 1.4.29 - the problem happens.

Hi You need to get a sip trace and read the upgrade notes, you may fined something there


I half remember a bug report about SIP redirect handling. It might be worth searching


thanks for your reply. I have already read the upgrade informations. But there is nothing mentioned about this. What would be the best way on how to get a sip-trace ?

“sip debug peer” and “rtp debug…” ?


sip set debug ip x.x.x.x

or, with low traffic
sip set debug on

or Wireshark

If you think you may need to submit a bug report, you need to follow the bug reporting guidelines for SIP bugs, which include sip set debug on.


i just did a sip debug…but it seems, that there is nothing that we could use to find the problem:

extension 100 called extension 20…20 did a call forwarding (by phone) to the extension 5. Ext 5 is a Playback thing. Ext 100 couldnt hear anything.


    -- Executing [20@intern:1] Set("SIP/100-00004a2f", "__TRANSFER_CONTEXT=transfercontext") in new stack
    -- Executing [20@intern:2] Dial("SIP/100-00004a2f", "SIP/20") in new stack
Audio is at port 19366
Adding codec 0x4 (ulaw) to SDP
Adding codec 0x8 (alaw) to SDP
Adding non-codec 0x1 (telephone-event) to SDP
Reliably Transmitting (no NAT) to
INVITE sip:20@;line=5ot20rul SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK14984305;rport
From: "TEST" <sip:100@>;tag=as66284718
To: <sip:20@;line=5ot20rul>
Contact: <sip:100@>
Call-ID: 1582e2d96a5f148e21a1f3f5078e9108@
CSeq: 102 INVITE
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Thu, 18 Feb 2010 18:03:49 GMT
Supported: replaces
Content-Type: application/sdp
Content-Length: 254

o=root 3526 3526 IN IP4
c=IN IP4
t=0 0
m=audio 19366 RTP/AVP 0 8 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -

    -- Called 20
<--- SIP read from --->
SIP/2.0 302 Moved Temporarily
Via: SIP/2.0/UDP;branch=z9hG4bK14984305;rport=5060
From: "TEST" <sip:100@>;tag=as66284718
To: <sip:20@;line=5ot20rul>;tag=5o0taiaeir
Call-ID: 1582e2d96a5f148e21a1f3f5078e9108@
CSeq: 102 INVITE
Contact: <sip:5@;user=phone>
Diversion: <sip:20@;line=5ot20rul>;reason="unconditional"
Content-Length: 0

--- (9 headers 0 lines) ---
    -- Got SIP response 302 "Moved Temporarily" back from
Transmitting (no NAT) to
ACK sip:20@;line=5ot20rul SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK14984305;rport
From: "TEST" <sip:100@>;tag=as66284718
To: <sip:20@;line=5ot20rul>;tag=5o0taiaeir
Contact: <sip:100@>
Call-ID: 1582e2d96a5f148e21a1f3f5078e9108@
CSeq: 102 ACK
User-Agent: Asterisk PBX
Max-Forwards: 70
Content-Length: 0

    -- Now forwarding SIP/100-00004a2f to 'Local/5@intern' (thanks to SIP/20-00004a30)
    -- Executing [5@intern:1] Answer("Local/5@intern-387c,2", "") in new stack
    -- Executing [5@intern:2] Playback("Local/5@intern-387c,2", "ivrnbst-speech") in new stack
    -- <Local/5@intern-387c,2> Playing 'ivrnbst-speech' (language 'en')
Really destroying SIP dialog '1582e2d96a5f148e21a1f3f5078e9108@' Method: INVITE
  == Spawn extension (intern, 20, 2) exited non-zero on 'SIP/100-00004a2f'
  == Spawn extension (intern, 5, 2) exited non-zero on 'Local/5@intern-387c,2'
Really destroying SIP dialog '3c466de5dd58-cx0dnlnpait0' Method: ACK

EDIT: It seems, that there is no rtp traffic… :frowning: If i set the rtp debug on and dial from 100 to 5 i see alot of rtp traffic…but if i call 20 to get redirected to 5 - there is no rtp traffic…

The trace shows a redirect to a recorded announcement, which answers immediately. There is no time for ringback to be generated. I will assume that the local channel is an artifact of SIP redirect processing.

I would still go for checking

I think I remember seeing something to the effect that 1.2 passes redirects back to the caller. If that is true, there might be enough time for the caller to generate some ringback tone before the redirected call got processed.

Actually, in this case, unless you have Ringing explicitly in the dial plan, the phone will never be sent 180 Ringing, so if it is a SIP phone should never generate ringback. The destination phone sends a redirect without first sending Ringing and the extension 5 code answers the call without first signalling Ringing.

Hi again,

I am sorry - in this example (with the debug) I know, that there is no way to get the ringing - i dont want the ringing there… :wink:.

It was just another example, that I dont even hear the “playback”.

Actually I have 2 Problems

  1. If there is a 302 redirect from a phone to another phone - the caller does not hear a ringing - the call is just getting answered without a ringing. Its kinda strange for the guy who just called an extension, did not hear anything…and suddenly without hearing a ringing somebody says “HELLO!”.

  2. If there is a 302 redirect from a phone to an extension with playback - the caller does not hear the playback (my example) - I called the phone and did not hear the playback :frowning: If I call it directly (extension 5) i hear it…so there must be a problem with the 302 redirecting…

EDIT: Maybe there is something weirdo in my sip.conf ?

bindport = 5060
bindaddr =
externip= XX.XX.XX.XX
notifyringing = yes
notifyhold = yes
limitonpeers = yes

callerid="TEST" <100>


I am sorry to update that old problem again. But still - the problem is not solved. I am still having the problems with 1.4.29. I already opened a call on issues.asterisk - but still - no reply.

Is there something new about my Problem? latest Infos:

Thanks much!

The issue you reference shows that they have accepted that you have provided evidence of a bug, but they have not received any fixes for it. It could stay that way for a very long time unless someone capable of fixing it considers it sufficiently interesting. If it progresses, it will change to “Confirmed” status, then “Ready for Testing”, then “Closed”. (Sometimes it takes a time to have the status updated if someone provides a candidate patch, but the summary will have “[Patch]” prepended.


have a read of … ressinband

and set it to yes and see what happens , we have seen this type of behaviour and setting progressinband to yes “solves” it



thanks for the reply. I just tryed it - but still - it didnt work.

Default Settings:
  Context:                default
  Nat:                    RFC3581
  DTMF:                   rfc2833
  Qualify:                0
  Use ClientCode:         No
  Progress inband:        Yes
  Language:               de
  MOH Interpret:          default
  MOH Suggest:            
  Voice Mail Extension:   asterisk

I was calling an external extension - the local sip was forwarded to another internal sip. Still no ringing. As soon as the caller answeres the call - I can talk to him…only Problem is the missing ringing…