Asterisk 1.4.2 and Cisco/Selsius 12SP+

Does anyone have old 12SP+ phones working well with Asterisk 1.4.x?

I am having trouble with my cisco/selsius phones only working for the first call. For the first call, everything works exaclty as expected, but once I hang up, the sound does not work on the phones. If I pick up the phone for a second call, I do not hear any dialtone, but the asterisk console reports:

[color=brown][Mar 27 14:16:24] WARNING[28840]: chan_skinny.c:1255 find_subchannel_by_instance_reference: Could not find subchannel with reference ‘0’ on ‘computers’
– Starting simple switch on ‘130@computers’[/color]
Does anyone know what that error means?

I can dial, etc. but no sound on my end. If I call the phone from another one, asterisk reports that my phone is ringing, but there is no sound coming from the phone (ie the device does not ring).

I don’t have a Cisco contract to update the firmware… New phones could potentially be cheaper… If I have to scrap these old phones, then that’s not a big deal… it might even be a blessing.

Any ideas out there from an expert? :smile:
(as I am no expert!)

I have a Cisco ATA 186 that works fine, repeatedly as does my SJLabs softphone. The problem I am having seems to be related to my old phones. Perhaps there are some other things that are also not working. I’ll find them once I get past this latest hurdle. :smile:

I recently upraded my server that was running asterisk.

New Machine
New OS (Ubuntu Server)
New Asterisk
Moved X100P card from old machine
Moved some files and configs to new machine.
New-ish configs…

I had some trouble with my old config files from my previous asterisk installation (1.0.10) and ended up making samples in 1.4.2 and configuring them to work as I want.

from Skinny.conf

[quote]; Typical config for 12SP+
line => 140 ; Dial(Skinny/140@office)[/quote]

from extensions.conf

exten => 130,1,Dial(Skinny/130@computers,20,tr) ; Ring the interface, 20 seconds maximum
exten => 130,2,Voicemail(130,u) ; If unavailable, send to voicemail w/ unavail announce
exten => 130,3,Goto(mainmenu,s,2) ; If they press #, return to start
exten => 130,4,Voicemail(130,b) ; If busy, send to voicemail w/ busy announce
exten => 130,5,Goto(mainmenu,s,2) ; If they press #, return to start

exten => 140,1,Dial(Skinny/140@office,20,tr) ; Ring the interface, 20 seconds maximum
exten => 140,2,Voicemail(140,u) ; If unavailable, send to voicemail w/ unavail announce
exten => 140,3,Goto(mainmenu,s,2) ; If they press #, return to start
exten => 140,4,Voicemail(140,b) ; If busy, send to voicemail w/ busy announce
exten => 140,5,Goto(mainmenu,s,2) ; If they press #, return to start[/quote]

Have you solved your problem? I am having a very similar problem and I am stuck.

Does anybody know what “subchannel with reference 0” means and what should I be looking for to debug this?

Although I realised that there was a problem with the dialplan that I posted in my first message (it tends to loop :-), I have not been able to solve the problem with my phones.

I sort of solved the problem by purchasing two Grandstream Budgetone-200’s to use instead of my old selsius/cisco phones :frowning:

I’d still love to get these old phones up and running, but I think it may be hopeless.

I’ve had much better luck with the 1.4.x series of asterisk

please note though, that different point releases are giving the channel code a hard time.

(stick with the .even releases)