Anyone sending or receive faxes in asterisk?


#1

Anyone successfully receiving or sending faxes with asterisk? If so what providers are you using. I have tried several providers but none can successfully receive or send a multi page fax with spandsp.


#2

ToddB:

What is ‘spandsp’? Let me guess. Is it some sort of software-only driver?

Your problem seems to be very similar to the horrible audio quality that many folks are experiencing.

Here is a posting from someone who has sucessfully managed to handle fax traffic. Notice how he has TWO hardware boards with Digital Signal Processors (DSP) inside. That’s the only way to capture and generate the audio in real time. Regardless of whether you get the fastest computer on earth loaded with RAM and whatnot, Linux is NOT a real time operating system, a small detail that Digium has not advertised too much.

-Ramon

[hylafax.org/archive/2004-07/msg00096.html](http://www.hylafax.org/archive/2004-07/msg00096.html)

#3

Well we run freebsd so that shouldn’t be the problem :smile: In theory any direct hand off from a SIP provider like Level3 should work. But the problem is these providers are all running the data through asterisk servers. If I knew of a provider that just proxied the sip messages only, and sent the RTP streams directly to me, faxes should work most of the time.


#4

I have successfully received 3 of 3 faxes using Asterisk and spandsp, but I haven’t tried sending.


#5

Using what provider?


#6

Using stanaphone sip account.