AMI does not receive requests

Hello,

I Have Asterisk certified/16.8-cert12 on Centos 7.9

Work incident that prompted the questions below.

At work, we’re using socket AMIs to pause and wake members of our support queue. Additionally we use it to bring the information about the queues and show it to a Dashboard that we build.

This works has worked fine for several months. For a couple of days it has happened to us that the AMI stops receiving requests and only by restarting the asterisk services does it work again.

When this happens to us and we run show eventq in the cli manager, it returns a large number of results (we don’t know if this is normal).

On the server side, the resources are seen with sufficient pride when we have the situation.

What could be causing the situation? In the logs we do not see anything strange.

Hi if you are using certified you should contact sangoma support
if you do not have a service agreement with sangoma you should us the normal asterisk 16.26.1

in tha CLI what do

asterisk -x "manager show connected"

also do it work if you try connect localy

telnet localhost 5038

Thanks for replying The Mark, when I have the problem and I run asterisk -x “manager show connected” this is the output:

asterisk -x “manager show connected” :

telnet localhost 5038:

After restart:
asterisk -x “manager show connected” :

can you post you manager.conf
also do you have any FW setup on it ?

to login with telnet past this (the last blank line is important)

Action: Login
ActionID: 1
Username: USERNAME
Secret: PASSWORD

can you also try do the telnet / login from the remote server to see if you can connect

this is manager.conf:

I can connect by telnet when I pass the credentials, including remotely.

Please don’t post pictures.

  1. Pictures cannot be searched.
  2. Pictures cannot be ‘cut-n-pasted’ into a known working configuration.
  3. Pictures cannot be quoted in replies.
  4. Pictures are not included in the mailing list cross-post. (The mailing list provides a link to the picture, but it’s still a PITA.)

hmm config look fine
guess we have to get it stuck again to troubleshoot
can you try login local and remote when it happens again

what command do you use for ?
we run show eventq in the cli manager

Strongly agree about not posting pictures.

This:
image

should either be:

permit=127.0.0.1/255.255.255.255
permit=192.168.1.45/255.255.255.255
permit=192.168.0.106/255.255.255

or

permit=127.0.0.0/255.255.255.0
permit=192.168.0.0/255.255.254.0

Depending on what you really intended to achieve. I suspect you will get the latter, although it is not guaranteed, but I suspect you wanted the former. An alternative implementation would never match any address.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.