All Circuits are busy


#1

HI

I am very new at aterisk, i have installed today a first copy of it using the Asterisk@Home version and i have managed to make calls localy through different extenesions. i am trying to setup as peoplecall as international voip provider and i have managed to and i have a confirmation that user is registered at their server but whenever i am trying to make a call i recieve

" All Circuits are busy please try again later" after that i just did a test using the VOIP Buster and i have the same problem.

i am searching on the net all day long but i was unable to find a solution.

thank you in adavance for your help.


#2

you’ll need to post the output from the Asterisk console so we can debug your problem. first, read the Asterisk@Home documentation to see how to view the console. One way to do this is open up a console in Linux and type:

asterisk -rcvvvvvvvvvv

that will open the console. then try making the call and view the output in the console. that might give you a clue. if not, post that output here.


#3

Connected to Asterisk 1.2.1 currently running on asterisk1 (pid = 2510)
Verbosity was 3 and is now 10
– Remote UNIX connection
– Executing Macro(“SIP/200-b835”, “dialout-trunk|4|37744112584|”) in new stack
– Executing GotoIf(“SIP/200-b835”, “1?3:2)”) in new stack
– Goto (macro-dialout-trunk,s,3)
– Executing Macro(“SIP/200-b835”, “user-callerid”) in new stack
– Executing DBget(“SIP/200-b835”, “AMPUSER=DEVICE/200/user”) in new stack
– DBget: varname=AMPUSER, family=DEVICE, key=200/user
– DBget: set variable AMPUSER to 200
– Executing DBget(“SIP/200-b835”, “AMPUSERCIDNAME=AMPUSER/200/cidname”) in new stack
– DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=200/cidname
– DBget: set variable AMPUSERCIDNAME to 200
– Executing GotoIf(“SIP/200-b835”, “0?5”) in new stack
– Executing SetCallerID(“SIP/200-b835”, ““200” <200>”) in new stack
– Executing NoOp(“SIP/200-b835”, “Using CallerID “200” <200>”) in new stack
– Executing Macro(“SIP/200-b835”, “record-enable|200|OUT”) in new stack
– Executing GotoIf(“SIP/200-b835”, “0 > 0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing AGI(“SIP/200-b835”, “recordingcheck|20060112-020906|1137049745.5”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20060112-020906|1137049745.5: Outbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing NoOp(“SIP/200-b835”, “No recording needed”) in new stack
– Executing Macro(“SIP/200-b835”, “outbound-callerid|4”) in new stack
– Executing DBget(“SIP/200-b835”, “USEROUTCID=AMPUSER/200/outboundcid”) in new stack
– DBget: varname=USEROUTCID, family=AMPUSER, key=200/outboundcid
– DBget: set variable USEROUTCID to
– Executing GotoIf(“SIP/200-b835”, “1?4”) in new stack
– Goto (macro-outbound-callerid,s,4)
– Executing GotoIf(“SIP/200-b835”, “1?6”) in new stack
– Goto (macro-outbound-callerid,s,6)
– Executing NoOp(“SIP/200-b835”, “CallerID set to “200” <200>”) in new stack
– Executing SetGroup(“SIP/200-b835”, “OUT_4”) in new stack
– Executing CheckGroup(“SIP/200-b835”, “”) in new stack
– Executing SetVar(“SIP/200-b835”, “DIAL_NUMBER=37744112584”) in new stack
– Executing SetVar(“SIP/200-b835”, “DIAL_TRUNK=4”) in new stack
– Executing AGI(“SIP/200-b835”, “fixlocalprefix”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
– AGI Script fixlocalprefix completed, returning 0
– Executing SetVar(“SIP/200-b835”, “OUTNUM=37744112584”) in new stack
– Executing Cut(“SIP/200-b835”, “custom=OUT_4|:|1”) in new stack
– Executing GotoIf(“SIP/200-b835”, “0?16”) in new stack
– Executing Dial(“SIP/200-b835”, “SIP/voipbuster/37744112584”) in new stack
– Called voipbuster/37744112584
– SIP/voipbuster-f633 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)
– Executing Goto(“SIP/200-b835”, “s-CONGESTION|1”) in new stack
– Goto (macro-dialout-trunk,s-CONGESTION,1)
– Executing NoOp(“SIP/200-b835”, “Dial failed due to CONGESTION”) in new stack
– Executing Macro(“SIP/200-b835”, “outisbusy”) in new stack
– Executing Playback(“SIP/200-b835”, “all-circuits-busy-now”) in new stack
– Playing ‘all-circuits-busy-now’ (language ‘en’)
– Executing Playback(“SIP/200-b835”, “pls-try-call-later”) in new stack
– Playing ‘pls-try-call-later’ (language ‘en’)
– Executing Macro(“SIP/200-b835”, “hangupcall”) in new stack
– Executing ResetCDR(“SIP/200-b835”, “w”) in new stack
– Executing NoCDR(“SIP/200-b835”, “”) in new stack
– Executing Wait(“SIP/200-b835”, “5”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘SIP/200-b835’ in macro ‘hangupcall’
== Spawn extension (macro-outisbusy, s, 3) exited non-zero on ‘SIP/200-b835’ in macro ‘outisbusy’
== Spawn extension (from-internal, 01237744112584, 2) exited non-zero on ‘SIP/200-b835’
– Executing Macro(“SIP/200-b835”, “hangupcall”) in new stack
– Executing ResetCDR(“SIP/200-b835”, “w”) in new stack
– Executing NoCDR(“SIP/200-b835”, “”) in new stack
– Executing Wait(“SIP/200-b835”, “5”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘SIP/200-b835’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/200-b835’
asterisk1*CLI>


#4

everything seems to be set up pretty much correctly. it’s odd that both voipbuster and peoplecall are failing. does the Asterisk box have internet access? can you ping google from the asterisk box? if you had the wrong username/password i believe the console would alert you. i have a feeling that the asterisk box isn’t reaching your provider due to a networking issue.


#5

Asterisk has internet connection, untill now it was after NAT and i have just provided it with public ip addres which is not Nated. and again the same problem.

below you will see that i can ping from asterisk

For help on Asterisk@Home commands you can use from this
command shell type help-aah.

[root@asterisk1 ~]# ping sip.peoplecall.com
PING sip.peoplecall.com (62.22.20.194) 56(84) bytes of data.
64 bytes from mgk4.peoplecall.com (62.22.20.194): icmp_seq=0 ttl=47 time=121 ms
64 bytes from mgk4.peoplecall.com (62.22.20.194): icmp_seq=1 ttl=47 time=142 ms
64 bytes from mgk4.peoplecall.com (62.22.20.194): icmp_seq=2 ttl=47 time=131 ms

[root@asterisk1 ~]# traceroute sip.peoplecall.com
traceroute to sip.peoplecall.com (62.22.20.194), 30 hops max, 38 byte packets
1 80.80.166.73 (80.80.166.73) 0.699 ms 0.425 ms 0.181 ms
2 80.80.166.254 (80.80.166.254) 22.015 ms 49.416 ms 64.058 ms
3 80.80.160.48 (80.80.160.48) 91.156 ms 29.665 ms 27.885 ms
4 80.80.160.138 (80.80.160.138) 74.125 ms 69.619 ms 38.906 ms
5 209.200.156.169 (209.200.156.169) 107.083 ms 99.783 ms 87.206 ms
6 209.200.156.81 (209.200.156.81) 92.104 ms 84.615 ms 95.854 ms
7 209.200.156.122 (209.200.156.122) 92.837 ms 90.916 ms 101.430 ms
8 ge-1-2-0.425.ar2.LON3.gblx.net (64.208.222.141) 93.516 ms 110.922 ms 114.391 ms
9 so0-0-0-2488M.ar1.AMS1.gblx.net (67.17.65.230) 139.613 ms 131.773 ms 100.779 ms
10 wcom-1.ar1.AMS1.gblx.net (208.50.13.162) 120.044 ms 108.433 ms 110.809 ms
11 so-0-2-0.TR2.AMS2.ALTER.NET (146.188.3.217) 94.845 ms 95.446 ms 144.971 ms
12 so-7-0-0.TR1.MAD3.ALTER.NET (146.188.3.205) 135.284 ms 131.784 ms 160.848 ms
13 0.so-5-0-0.XR2.MAD3.ALTER.NET (146.188.8.106) 135.380 ms 172.519 ms 158.783 ms
14 POS12-0.GW1.MAD3.ALTER.NET (146.188.8.246) 148.876 ms 153.648 ms 146.855 ms
15 peopletel-gw.customer.ALTER.NET (146.188.48.210) 150.996 ms 130.556 ms 141.765 ms


#6

well, i’m not too sure what it could be. what about the number you are dialing, 37744112584? that’s a weird number. are you able to dial a regular phone number with 00 and the country code? For example 0019545245551.


#7

i have just tried to make some changes on the TRUNK and Outside Routing
this is the message i am recieving,

– Called peoplecall/000038138552222
– Got SIP response 415 “Unsupported Media Type” back from 62.22.20.194

i am suprised with this one what do you think this is? a missing codec?

does the A@H support g729 i was not able to find it.

– Executing Macro(“SIP/200-b496”, “dialout-trunk|2|0038138552222|”) in new stack
– Executing GotoIf(“SIP/200-b496”, “1?3:2)”) in new stack
– Goto (macro-dialout-trunk,s,3)
– Executing Macro(“SIP/200-b496”, “user-callerid”) in new stack
– Executing DBget(“SIP/200-b496”, “AMPUSER=DEVICE/200/user”) in new stack
– DBget: varname=AMPUSER, family=DEVICE, key=200/user
– DBget: set variable AMPUSER to 200
– Executing DBget(“SIP/200-b496”, “AMPUSERCIDNAME=AMPUSER/200/cidname”) in new stack
– DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=200/cidname
– DBget: set variable AMPUSERCIDNAME to 200
– Executing GotoIf(“SIP/200-b496”, “0?5”) in new stack
– Executing SetCallerID(“SIP/200-b496”, ““200” <200>”) in new stack
– Executing NoOp(“SIP/200-b496”, “Using CallerID “200” <200>”) in new stack
– Executing Macro(“SIP/200-b496”, “record-enable|200|OUT”) in new stack
– Executing GotoIf(“SIP/200-b496”, “0 > 0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing AGI(“SIP/200-b496”, “recordingcheck|20060112-161229|1137100349.14”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20060112-161229|1137100349.14: Outbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing NoOp(“SIP/200-b496”, “No recording needed”) in new stack
– Executing Macro(“SIP/200-b496”, “outbound-callerid|2”) in new stack
– Executing DBget(“SIP/200-b496”, “USEROUTCID=AMPUSER/200/outboundcid”) in new stack
– DBget: varname=USEROUTCID, family=AMPUSER, key=200/outboundcid
– DBget: set variable USEROUTCID to
– Executing GotoIf(“SIP/200-b496”, “0?4”) in new stack
– Executing SetCallerID(“SIP/200-b496”, “34700758574001”) in new stack
– Executing GotoIf(“SIP/200-b496”, “1?6”) in new stack
– Goto (macro-outbound-callerid,s,6)
– Executing NoOp(“SIP/200-b496”, “CallerID set to 34700758574001”) in new stack
– Executing SetGroup(“SIP/200-b496”, “OUT_2”) in new stack
– Executing CheckGroup(“SIP/200-b496”, “”) in new stack
– Executing SetVar(“SIP/200-b496”, “DIAL_NUMBER=0038138552222”) in new stack
– Executing SetVar(“SIP/200-b496”, “DIAL_TRUNK=2”) in new stack
– Executing AGI(“SIP/200-b496”, “fixlocalprefix”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
– AGI Script fixlocalprefix completed, returning 0
– Executing SetVar(“SIP/200-b496”, “OUTNUM=000038138552222”) in new stack
– Executing Cut(“SIP/200-b496”, “custom=OUT_2|:|1”) in new stack
– Executing GotoIf(“SIP/200-b496”, “0?16”) in new stack
– Executing Dial(“SIP/200-b496”, “SIP/peoplecall/000038138552222”) in new stack
– Called peoplecall/000038138552222
– Got SIP response 415 “Unsupported Media Type” back from 62.22.20.194
== No one is available to answer at this time (1:0/0/0)
– Executing Goto(“SIP/200-b496”, “s-NOANSWER|1”) in new stack
– Goto (macro-dialout-trunk,s-NOANSWER,1)
– Executing NoOp(“SIP/200-b496”, “Dial failed due to NOANSWER”) in new stack
– Executing Macro(“SIP/200-b496”, “dialout-trunk|3|0038138552222|”) in new stack
– Executing GotoIf(“SIP/200-b496”, “1?3:2)”) in new stack
– Goto (macro-dialout-trunk,s,3)
– Executing Macro(“SIP/200-b496”, “user-callerid”) in new stack
– Executing DBget(“SIP/200-b496”, “AMPUSER=DEVICE/34700758574001/user”) in new stack
– DBget: varname=AMPUSER, family=DEVICE, key=34700758574001/user
– DBget: Value not found in database.
– Executing DBget(“SIP/200-b496”, “AMPUSERCIDNAME=AMPUSER/200/cidname”) in new stack
– DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=200/cidname
– DBget: set variable AMPUSERCIDNAME to 200
– Executing GotoIf(“SIP/200-b496”, “0?5”) in new stack
– Executing SetCallerID(“SIP/200-b496”, ““200” <200>”) in new stack
– Executing NoOp(“SIP/200-b496”, “Using CallerID “200” <200>”) in new stack
– Executing Macro(“SIP/200-b496”, “record-enable|200|OUT”) in new stack
– Executing GotoIf(“SIP/200-b496”, “0 > 0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing AGI(“SIP/200-b496”, “recordingcheck|20060112-161237|1137100349.14”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
– Got SIP response 415 “Unsupported Media Type” back from 62.22.20.194
recordingcheck|20060112-161237|1137100349.14: Outbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing NoOp(“SIP/200-b496”, “No recording needed”) in new stack
– Executing Macro(“SIP/200-b496”, “outbound-callerid|3”) in new stack
– Executing DBget(“SIP/200-b496”, “USEROUTCID=AMPUSER/200/outboundcid”) in new stack
– DBget: varname=USEROUTCID, family=AMPUSER, key=200/outboundcid
– DBget: set variable USEROUTCID to
– Executing GotoIf(“SIP/200-b496”, “0?4”) in new stack
– Executing SetCallerID(“SIP/200-b496”, “34700758574002”) in new stack
– Executing GotoIf(“SIP/200-b496”, “1?6”) in new stack
– Goto (macro-outbound-callerid,s,6)
– Executing NoOp(“SIP/200-b496”, “CallerID set to 34700758574002”) in new stack
– Executing SetGroup(“SIP/200-b496”, “OUT_3”) in new stack
– Executing CheckGroup(“SIP/200-b496”, “1”) in new stack
– Executing SetVar(“SIP/200-b496”, “DIAL_NUMBER=0038138552222”) in new stack
– Executing SetVar(“SIP/200-b496”, “DIAL_TRUNK=3”) in new stack
– Executing AGI(“SIP/200-b496”, “fixlocalprefix”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
– AGI Script fixlocalprefix completed, returning 0
– Executing SetVar(“SIP/200-b496”, “OUTNUM=000038138552222”) in new stack
– Executing Cut(“SIP/200-b496”, “custom=OUT_3|:|1”) in new stack
– Executing GotoIf(“SIP/200-b496”, “0?16”) in new stack
– Executing Dial(“SIP/200-b496”, “SIP/peoplecall2/000038138552222”) in new stack
– Called peoplecall2/000038138552222
– Got SIP response 415 “Unsupported Media Type” back from 62.22.20.194
== No one is available to answer at this time (1:0/0/0)
– Executing Goto(“SIP/200-b496”, “s-NOANSWER|1”) in new stack
– Goto (macro-dialout-trunk,s-NOANSWER,1)
– Executing NoOp(“SIP/200-b496”, “Dial failed due to NOANSWER”) in new stack
– Executing Macro(“SIP/200-b496”, “outisbusy”) in new stack
– Executing Playback(“SIP/200-b496”, “all-circuits-busy-now”) in new stack
– Playing ‘all-circuits-busy-now’ (language ‘en’)
– Executing Playback(“SIP/200-b496”, “pls-try-call-later”) in new stack
– Playing ‘pls-try-call-later’ (language ‘en’)
== Spawn extension (macro-outisbusy, s, 2) exited non-zero on ‘SIP/200-b496’ in macro ‘outisbusy’
== Spawn extension (from-internal, 0038138552222, 3) exited non-zero on ‘SIP/200-b496’
– Executing Macro(“SIP/200-b496”, “hangupcall”) in new stack
– Executing ResetCDR(“SIP/200-b496”, “w”) in new stack
– Executing NoCDR(“SIP/200-b496”, “”) in new stack
– Executing Wait(“SIP/200-b496”, “5”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘SIP/200-b496’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/200-b496’


#8

-- Called peoplecall/000038138552222 -- Got SIP response 415 "Unsupported Media Type" back from 62.22.20.194 == No one is available to answer at this time (1:0/0/0)
once again that number is crazy. why so many 0s? try dialing a normal number. try that one i listed, 0019545245551. it’s a hotel, they won’t mind.

asterisk DOES NOT include g729 and i believe that peoplecall may require it. try a different provider with ulaw (g711) or gsm.