AAH 1.5 +TDM400 4 FXO does not detect hang up


#1

Hi there,
I have A@H 1.5 and a TDM400 with 4 FXO, trying to set it up in rural Manitoba Canada.
My telco (Manitoba Telecom) has told me that the service it provides for this town is Loop Start with no disconnect supervision.

I created a files named zapata_costum.conf and added the following line to zapata.conf:
include zapata_costum.conf

In zapata_costum.conf I had the following lines:

progzone=ca (also tried =us)
callprogress=yes
busydetect=yes
busycount=6
(the line doesn’t make a busy tone though after the incoming caller hangs up, so this option might not work for my case anyway).

Besides this I had changed signaling=fxs_ls in zapata.conf. In zaptel.conf I also changed the setting from ks to ls and did a ztcfg -vvvv.

Nothing has helped so far, Asterisk still doesn’t not detect when the incoming call (PSTN) hangs up.
I tried the same A@H box in a different city where the telco provides disconect supervision, and there it works with the default settings.

Has anyone got callprogress and busydetect to work in A@H?

Please, can anyone help me?

Thanks.