ZTDummy help

I’ve been trying to install Asterisk/FreePBX for the last few days and am stuck.

The problems I run into I believe are related to the fact that I don’t have any analog cards.

When I try to start Asterisk, I get the following error:
[chan_oss.so] => (OSS Console Channel Driver)
Dec 13 09:39:19 NOTICE[31980]: chan_oss.c:1380 load_module: Unable to load config oss.conf
Dec 13 09:39:19 WARNING[31980]: loader.c:415 __load_resource: chan_oss.so: load_module failed, returning -1
Dec 13 09:39:19 WARNING[31980]: loader.c:555 load_modules: Loading module chan_oss.so failed!

When I try renaming the chan_oss.so file to something different, it gets past that and then says chan_phone.so can load. When I rename that one, chan_zap.so won’t load. After I rename that, Asterisk will start.

Is this all related to not having ZTDummy setup properly?

What is the correct procedure to setup ZTDummy? I’ve followed the procedures here: aussievoip.com.au/wiki/ztdummy

But those seem to be a bit out of date. I still have the same errors.

Even after renaming the files as a work around, FreePBX’s start script doesn’t work.

I have tried this using Ubuntu 6.06 server and CentOS 4.5 server.

Any ideas?