Zap channel faxing in or out fails but phone calls work

I have AAH2.8 on a dual Xeon system with a Sangoma A104 and an Adtran Channel Bank.

The system has a single PRI connected to port 1 and port 2 has the T1 cable connected to the Channel Bank. Both are configured properly and work for the inbound/outbound calls and soft-fax reception.

I have fax machines connected to FXS ports on the channel bank. The idea here is to allow faxing out over the PRI from these FXS ports and for inbound DIDs to go to specific fax machines.

I have Asterisk@Home 2.8 setup on this system and I am pretty certain I have it configured correctly.

  • Each fax machine has it’s own Zap extension.
  • The DID routes to the correct fax machine (zap extension).
  • I can make and receive phone calls with these fax machines. Meaning, the fax machine has a phone hand set. I can call out with that handset and receive calls on that handset.

Here’s the problem. When I try send or receive faxes it fails telling me there was a com error.

Any ideas?

I am at a loss. I have followed the logs. The transmit and receive work. Once the connection is made it fails indicating “com error”.

Additionally, I hear the “whistle and chirp” of fax machines talking to each other. Combined with being able to make and receive calls over those fax machine hand sets I don’t know what the problem is at this point.

Please, if anyone has fax machines setup with a similar situation I would appreciate knowing how you have it setup.

OS - CentOS 4.3
zaptel - 1.2.5
libpri - 1.2.3
asterisk -
freepbx - 2.0.1

Thank you.

in zapata.conf make sure echocancelwhenbridged=no. Also make sure your channel bank is not doing any kind of echo cancelling on the fax ports. Lastly, check the Sangoma driver setup (its separate from the zaptel setup) and make sure that the fax port has echo cancel always turned off, and that whatever the sangoma equivalent of echocancelwhenbridged is is disabled.

hope that helps!

I will look into the sangoma configs to see if there is a way to turn off echocan for port 2.

I did disable the echocan for those channels. Additionally, I am “tweaking” the rx and tx gains for those channels to see if that helps.

Thank you.

Someone from asterisk-users mailing suggested a driver update from Sangoma.

I upgraded the driver and it works great.

Thanks, to all those that posted. I appreciate the suggestions.