Wrong Password SIP Asterisk 13.20.0.rc2

On March 13, 2018, I installed Asterisk 13.20.0.rc2 for Centos 7 Server on GCP x86_64, Zoiper Sip Client Registers and I called myself. Now have to tweak the Google Cloud Platform Hosted PBX for security and real-time voice packets.

Yesterday I tried the same procedure and received a message that I had the “wrong password.” Nothing changed. Why is this happening?!

Without providing information or looking into it noone can tell you why it isn’t working.

For example, what’s the Asterisk console output? does it say anything about the attempt? what’s the configuration? do you see the messages if “pjsip set logger on” is done?

1 Like

I will update the post shortly.

@jcolp here you go:

[Mar 14 22:33:37] e[1;33mNOTICEe[0m[17639]: e[1;37mchan_sip.ce[0m:e[1;37m28680e[0m e[1;37mhandle_request_registere[0m: Registration from ‘"Eddie"sip:xxxx@x.x.x.x:5060;transport=UDP’ failed for ‘x.x.x.x:53856’ - Wrong password

Are you using chan_sip (and not chan_pjsip)? Have you examined the configuration and confirmed it matches?

@jcolp I have to check and get back to you primo?

@jcolp this is the issue The module ‘chan_pjsip’ was not properly initialized. Before reloading the module, you must run “module load chan_pjsip” and fix whatever is preventing the module from being initialized.

Then I tried reloading some modules and received the following:

*CLI> module load chan_pjsip
Unable to load module chan_pjsip
Command ‘module load chan_pjsip’ failed.
*CLI> module reload chan_pjsip
The module ‘chan_pjsip’ was not properly initialized. Before reloading the module, you must run “module load chan_pjsip” and fix whatever is preventi
ng the module from being initialized.
*CLI> module load res_pjproject.so
Unable to load module res_pjproject.so
Command ‘module load res_pjproject.so’ failed.
*CLI> [Mar 17 20:16:30] WARNING[1969]: loader.c:1170 load_resource: Module ‘res_pjproject.so’ already loaded and running.
*CLI> module load res_pjsip.so
Unable to load module res_pjsip.so
Command ‘module load res_pjsip.so’ failed.
*CLI> [Mar 17 20:17:23] WARNING[1969]: sorcery.c:861 __ast_sorcery_insert_wizard_mapping: Wizard ‘realtime’ failed to open mapping for object type ‘e
ndpoint’ with data: ps_endpoints
[Mar 17 20:17:23] ERROR[1969]: sorcery.c:634 __ast_sorcery_open: Error attempting to apply configuration res_pjsip to sorcery.
[Mar 17 20:17:23] ERROR[1969]: res_pjsip/config_system.c:157 ast_sip_initialize_system: Failed to open SIP system sorcery
[Mar 17 20:17:23] ERROR[1969]: res_pjsip.c:4852 load_module: Failed to initialize SIP ‘system’ configuration section. Aborting load
*CLI> module load chan_pjsip.so
Unable to load module chan_pjsip.so
Command ‘module load chan_pjsip.so’ failed.

Then I checked on this site for this issue and you dealt with this in the past:

I still have the original ubuntu server with 13.18.5 and chan_pjsip is loaded and running using the same pjsip.conf file.