Why RX JITTER is always 0.000000?

Hi,
I am playing with voice quality statistics for my sip calls and I need to clear something strange to me.

I have RTCP in both directions but after the call hangup I can see that rx jitter is always reported as 0.000000

In the h extension I am calling a macro which is using ${CHANNEL(rtpqos,audio,all)} to report all needed parameters to calculate MOS.

Executing [s@macro-rtcp3:3] NoOp("SIP/PS1-0000015a", "RTPAUDIOQOS: ssrc=474481140;themssrc=2176743560;lp=0;rxjitter=0.000000;rxcount=466;txjitter=0.000038;txcount=465;rlp=1;rtt=0.251255") in new stack
Executing [s@macro-rtcp3:4] NoOp("SIP/PS1-0000015a", "RTPAUDIOQOSBRIDGED: ssrc=1048430821;themssrc=1723414528;lp=0;rxjitter=0.000000;rxcount=465;txjitter=0.000140;txcount=466;rlp=0;rtt=0.215690") in new stack

I don’t think rjxitter is 0 because I’ve captured the call and I can see in wireshark there is jitter in both directions. At the same time all the presentations related to qos I found over the internet show rxjitter 0 too… I think there is something wrong. Any idea?

I am using default provided by ubuntu 16.04 lts Asterisk 13.1.0

Regards,
Pavel Siderov

Anything that “calculates” MOS based on jitter is only estimating it, not measuring it, as it can only be measured using opinions from a panel of humans. Also, based on rather a short bit of research, it looks liike jitter is actually used to to estimate packet loss and it is the packet loss that actually predicts the MOS degradation. The TX jitter figures you quote shouldn’t be causing packet loss, so there would be no degradation estimated.

I don’t know why RX Jitter is being reported as zero.

Yeah, I am pretty aware it is estimating it. I’ve read a lot on the topic but the case is why rx jitter is always reported as 0.000000?

Theorizing why is not something I’d do with such an old version of Asterisk. There have been bug fixes in RTCP which may alter the result.

Ok, I will upgrade and provide feedback later again.

Tested with Asterisk 13.18.3~dfsg-1ubuntu4 (default provided by Ubuntu 18.04.3 LTS) and got the same result:

-- Executing [s@macro-rtcp3:2] NoOp("SIP/PS1-00000000", "-- QoS stats ssrc=745171835;themssrc=20286839;lp=16;rxjitter=0.000000;rxcount=7522;txjitter=0.000042;txcount=7522;rlp=1;rtt=0.027587") in new stack
-- Executing [s@macro-rtcp3:3] NoOp("SIP/PS1-00000000", "-- QoS stats RTPAUDIOQOS: ssrc=745171835;themssrc=20286839;lp=16;rxjitter=0.000000;rxcount=7522;txjitter=0.000042;txcount=7522;rlp=1;rtt=0.027587") in new stack

Is this version ok or you want me to compile the latest 13.*

I always recommend the latest version when a problem is encountered, because chasing old problems is never fun.

Ok, just compiled 13.28.0

Got the same result:
– Executing [s@macro-rtcp3:2] NoOp(“SIP/PS1-00000000”, “-- QoS stats ssrc=1387192683;themssrc=137373955;lp=0;rxjitter=0.000000;rxcount=487;txjitter=0.000147;txcount=487;rlp=1;rtt=0.019027”) in new stack
– Executing [s@macro-rtcp3:3] NoOp(“SIP/PS1-00000000”, “-- QoS stats RTPAUDIOQOS: ssrc=1387192683;themssrc=137373955;lp=0;rxjitter=0.000000;rxcount=487;txjitter=0.000147;txcount=487;rlp=1;rtt=0.019027”) in new stack