What this error mean which I get while AGI


 Couldn't negotiate stream 0:audio-0:audio:sendrecv (nothing)

I implement one AGI script app but I facing the above issue.
I paste official GitHub repo link from where I implemented, https://zaf.github.io/asterisk-speech-recog/
I am doing the exact same thing except for my extensions.conf file where I have changed some.


exten = _11XX,hint,PJSIP/${EXTEN}

;Simple speech recognition
exten => _11XX,1,Answer()
exten => _11XX,n,agi(speech-recog.agi,en-US)
exten => _11XX,n,Verbose(1,The text you just said is: ${utterance})
exten => _11XX,n,Verbose(1,The probability to be right is: ${confidence})
exten => _11XX,n,Hangup()

Also, I can’t even make calls so maybe my script never reaches exten => _11XX,1,Answer() because of that I can’t figure out where exactly problem occurring.

Thanks in advance

The message is incomplete, as it does not contain the file and line number that generated it, nor the severity. However it doesn’t look like it isn’t AGI related, it looks, like you tried to select a set of codecs that was incompatible with the peer. Maybe you didn’t enable any audio codecs at all.

[Jan 20 17:10:38] ERROR[2870]: res_pjsip_session.c:934 handle_incoming_sdp:  1101: Couldn't negotiate stream 0:audio-0:audio:sendrecv (nothing)

hey, david I got only this error message after enabling verbose to 5 and debug to 5.

And also it is containing file in agi-bin as I mentioned in post I try to follow one github repo in that repo there is one file speech-recog.agi which I pasted in /var/lib/asterisk/agi-bin/.

You said about codecs, yeah it can be involved in this because what I trying to implement is something speech recoginization so it might possible.

But still I can’t figure out why I can’t make a call and If there is file error then it could be shown in console.

You would need to provide the output of “pjsip set logger on” with a call attempt, and also the configuration of the endpoint.

hey jcolp I enabled pjsip set logger on and make a call for 3 sec but there is huge log so should I provide whole log ? and one thing I couldn’t get configure endpoint? I already configured those and its registered successfully I can make call using them.

Correct me if I am wrong in perspective of endpoints sorry for my jargons barrier.

You can provide a link to it, yes. As well I’m asking for the configuration of the endpoint from pjsip.conf to understand what codecs are allowed.

i provide all files so rather than paste here
logs.txt (25.0 KB)
pjsip.txt (928 Bytes)
The agi file which I try to implement maybe it could help, (Note: I can’t post .agi file here so I change file extension to .txt so please take it as note)
speech-recog.txt (8.6 KB)
One last extensions.conf I thought It’ll link all thing because I spent most of my time here in this file
extensions.txt (373 Bytes)

The client is using a media type of “RTP/AVPF” but your endpoint configuration is not set to support that. You would need to set the “use_avpf” option on the “1101” endpoint to “yes” or to disable it on the client. Your problem is not related to your AGI.

thanks sir now I can test twice, Firstly I comment use_avpf = yes and then check it’s gave same error above with call attempt then I did reverse uncomment that and check and no error show in CLI.

One last question sorry but I think I should I asked here instead of create new thread, I do not see any warning, error or notice in cli and make a call but One thing I could not get why my agi file is not calling or just I need to enable that?

By the way thanks for your support because of your help I’m one step forward

That should be another thread, with actual further console output of what is seen and what happens.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.