What does "circuit-busy" mean when I try to make o

Just when I thought BroadVoice and Asterisk were working perfect together, I’ve run into a problem.

When I try to make an outgoing call, I get a “circuit-busy” response from sip.broadvoice.com:

Ignore the CALLERID stuff unless that’s the problem (I’m only using it to fool around and try to understand how it works).

Anyways, I was making perfectly fine phone calls out of BroadVoice until all of a sudden (eg. the last three or four hours).

Here is the relevant part of my extensions.conf:

exten => _9XXXXXXX,1,Set(CALLERID(number)=6135551234)
exten => _9XXXXXXX,2,Dial(SIP/1570${EXTEN:1}@sip.broadvoice.com,60)
exten => _9XXXXXXX,3,Set(CALLERID(number)=6135551234)
exten => _9XXXXXXX,4,Congestion

Any help is appriciated. Also, I’m sorry for being a pain and posting too many questions to the forums… (some of this Asterisk/SIP/VOIP stuff is confusing!)

well, did you try commenting out the CALLERID stuff and seeing if that was the problem ? what has changed from when you had it working ? if you go back to that config does it start working again ?

come on, this is simple, basic diagnostic principle. once you’ve removed the changes you’ve made and it still doesn’t work, try turning on “sip debug” at the CLI.

Yes, I’ve also added an extension like this:

exten => _0XXXXXXX,1,Dial(SIP/1570${EXTEN:1}@sip.broadvoice.com,60)
exten => _0XXXXXXX,2,Congestion 

(It’s prefixed with a zero instead of a nine).

However, I still get the same results :frowning:

I’ve also tried removing the “1570” part from the Dial() command, but that also doesn’t seem to help at all…

You might want to include your sip.conf (strip commented out sections). I’ve had a bit of experiencing sorting out broadvoice’s issues, but I need to see how you’re registering with them… Also, make sure your verbosity is set as high as it will go and if you get more info when trying to make the call, paste that in as well.