WebRTC and SIPML5 - Wrong password


#1

Hi there,

I’m using Asterisk 16.0.0 and I’d like to set up Webrtc and SIPML5. I followed this tutorial : https://wiki.asterisk.org/wiki/display/AST/WebRTC+tutorial+using+SIPML5
But when I try to login with SIPML5, I get this error :

WebSocket connection from ‘X.X.X.X:6609’ for protocol ‘sip’ accepted using version ‘13’
[Nov 21 15:41:05] NOTICE[29334]: chan_sip.c:28908 handle_request_register: Registration from ‘"WebRTC Client"sip:webrtc_client@XXXX.XX’ failed for ‘X.X.X.X:6609’ - Wrong password

Here’s my configuration :

pjsip.conf


[transport-wss]
type=transport
protocol=wss
bind=0.0.0.0
; All other transport parameters are ignored for wss transports.

[webrtc_client]
type=aor
max_contacts=5
remove_existing=yes
  
[webrtc_client]
type=auth
auth_type=userpass
username=webrtc_client
password=webrtc_client

[webrtc_client]
type=endpoint
aors=webrtc_client
auth=webrtc_client
dtls_auto_generate_cert=yes
webrtc=yes
; Setting webrtc=yes is a shortcut for setting the following options:
; use_avpf=yes
; media_encryption=dtls
; dtls_verify=fingerprint
; dtls_setup=actpass
; ice_support=yes
; media_use_received_transport=yes
; rtcp_mux=yes
context=internal
disallow=all
allow=ulaw

Any ideas?
Thanks a lot


#2

Assuming endpoint is using the correct credentials for its auth section all seems to be OK for me


#3

You have configured chan_pjsip, but you still have chan_sip loaded and it is responding to the websocket traffic. If you specifically unload chan_sip or noload it in modules.conf and restart then PJSIP will start responding instead. If you need chan_sip there is also an option, “websocket_enabled”, in sip.conf which can be set to no to disable it.


#4

It works!. Thank you