WebRTC And Asterisk 13 - 488 Not Acceptable Here


#1

Hi,

I have some problems when trying to connect to Asterisk and make calls using WebRTC.
I have installed Asterisk 13.12.1 using AsteriskNOW.
I am using SIP.js version 0.11.4. I was able to register successfully, but when I try to make call I receive 488 Not Acceptable Here.

My INVITE message is at the end of the post. I tried using UCP from FreePBX that comes installed from AsteriskNOW, and INVITE message is almost identical and the call was successful.
Difference is that UCP uses extension with prefix 99, where I do not.
I am not sure do I also need to use with prefix 99. I tried, but I was not able to register.

I also tried using SipML5, Sip.JS, JsSip demo phones, but I receive same error.

Am I doing something wrong?

Thanks.

INVITE sip:7777@sip.test SIP/2.0
Via: SIP/2.0/WSS dtq3ifi7cjiv.invalid;branch=z9hG4bK4117153
Max-Forwards: 70
To: <sip:7777@sip.test>
From: <sip:201@sip.test>;tag=abod0j4vj3
Call-ID: g0h6j9sqts26473a83dh
CSeq: 3696 INVITE
Authorization: Digest algorithm=MD5, username="201", realm="asterisk", nonce="1538746640/bfd2ca790065a37b2bc4ac258c4b0661", uri="sip:7777@sip.test", response="3a397c4aa4563124bd7aa1bfda5b0fe6", opaque="74874567628b3479", qop=auth, cnonce="9tgefoprg974", nc=00000001
Contact: <sip:5uq7qvmr@dtq3ifi7cjiv.invalid;transport=wss;ob>
Allow: ACK,CANCEL,INVITE,MESSAGE,BYE,OPTIONS,INFO,NOTIFY,REFER
Supported: outbound
User-Agent: SIP.js/0.11.4
Content-Type: application/sdp
Content-Length: 2035

v=0
o=- 2214769793224257501 2 IN IP4 127.0.0.1
s=-
t=0 0
a=group:BUNDLE audio
a=msid-semantic: WMS 7WoNgrQcPRnAqa9TMYP7TofwjezmeD7COPHx
m=audio 59214 UDP/TLS/RTP/SAVPF 111 103 104 9 0 8 106 105 13 110 112 113 126
c=IN IP4 85.94.124.155
a=rtcp:58733 IN IP4 85.94.124.155
a=candidate:4198389976 1 udp 2122260223 192.168.20.181 59214 typ host generation 0 network-id 1 network-cost 10
a=candidate:4198389976 2 udp 2122260222 192.168.20.181 58733 typ host generation 0 network-id 1 network-cost 10
a=candidate:3032327208 1 tcp 1518280447 192.168.20.181 9 typ host tcptype active generation 0 network-id 1 network-cost 10
a=candidate:3032327208 2 tcp 1518280446 192.168.20.181 9 typ host tcptype active generation 0 network-id 1 network-cost 10
a=candidate:917727051 2 udp 1686052606 85.94.124.155 58733 typ srflx raddr 192.168.20.181 rport 58733 generation 0 network-id 1 network-cost 10
a=candidate:917727051 1 udp 1686052607 85.94.124.155 59214 typ srflx raddr 192.168.20.181 rport 59214 generation 0 network-id 1 network-cost 10
a=ice-ufrag:YIaL
a=ice-pwd:eTkwehdfj/dXrW5yNNxmqnCF
a=ice-options:trickle
a=fingerprint:sha-256 12:6F:0F:07:5F:0D:B6:3C:8C:C9:5D:FD:EF:8D:44:7A:04:46:B8:C4:C0:47:6D:00:D8:10:A4:49:D0:68:2E:F6
a=setup:actpass
a=mid:audio
a=extmap:1 urn:ietf:params:rtp-hdrext:ssrc-audio-level
a=sendrecv
a=rtcp-mux
a=rtpmap:111 opus/48000/2
a=rtcp-fb:111 transport-cc
a=fmtp:111 minptime=10;useinbandfec=1
a=rtpmap:103 ISAC/16000
a=rtpmap:104 ISAC/32000
a=rtpmap:9 G722/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:106 CN/32000
a=rtpmap:105 CN/16000
a=rtpmap:13 CN/8000
a=rtpmap:110 telephone-event/48000
a=rtpmap:112 telephone-event/32000
a=rtpmap:113 telephone-event/16000
a=rtpmap:126 telephone-event/8000
a=ssrc:3131568490 cname:JpDijo7hZwGPvZhh
a=ssrc:3131568490 msid:7WoNgrQcPRnAqa9TMYP7TofwjezmeD7COPHx 3182947d-1acf-45ae-95f2-5411c849dfa9
a=ssrc:3131568490 mslabel:7WoNgrQcPRnAqa9TMYP7TofwjezmeD7COPHx
a=ssrc:3131568490 label:3182947d-1acf-45ae-95f2-5411c849dfa9

#2

The extension with a prefix of 99 is configured to allow WebRTC traffic. There is specific configuration in Asterisk needed to support it per-extension, and that configuration is incompatible with normal devices.


#3

Thank you very much. I found that I need to change password for extensions with prefix 99. When I do that I was able to make call.
Also, can you tell me what is different in using it this way in contrast the way that was defined in tutorial
https://wiki.asterisk.org/wiki/display/AST/WebRTC+tutorial+using+SIPML5.
Is this because of asterisk version, that in tutorial it is required Asterisk 15?