Waitforsilence giving error message

My waitforsilence command has been working fine as far as I know, but now I see it breaking through when I view the CLI. I went into the debug logs and saw the errors that come from this section of code in waitforsilence.

When I do a test call, I can hear asterisk talk to me after it breaks through. Using SIP channel g729 codec.

Can anyone elaborate for me about this error condition - what is means, why it occurs, what you have done to fix it? Thanks!

00093 /* Await silence... */ 00094 f = NULL; 00095 for(;;) { 00096 res = ast_waitfor(chan, 2000); 00097 if (!res) { 00098 ast_log(LOG_WARNING, "One waitfor failed, trying another\n"); 00099 /* Try one more time in case of masq */ 00100 res = ast_waitfor(chan, 2000); 00101 if (!res) { 00102 ast_log(LOG_WARNING, "No audio available on %s??\n", chan->name); 00103 res = -1; 00104 } 00105 }

I changed from a sip channel to IAX thinking for some reason I was getting one way audio even though regular phone calls go through ok. I read that this app has a problem with digital silence as well. Anyway, the error I had before goes away with IAX, but now I get timeout after only seven seconds. Any ideas?

Sep 22 12:52:43 VERBOSE[15435] logger.c: -- Executing Answer("IAX2/talklite-6", "") in new stack Sep 22 12:52:43 VERBOSE[15435] logger.c: -- Executing Wait("IAX2/talklite-6", "1") in new stack Sep 22 12:52:44 VERBOSE[15435] logger.c: -- Executing WaitForSilence("IAX2/talklite-6", "2000") in new stack Sep 22 12:52:44 VERBOSE[15435] logger.c: -- Waiting 1 time(s) for 2000 ms silence Sep 22 12:52:51 DEBUG[15435] app_waitforsilence.c: WAITSTATUS was set to TIMEOUT Sep 22 12:52:51 VERBOSE[15435] logger.c: -- Executing Goto("IAX2/talklite-6", "talk|2") in new stack

I changed to using BackgroundDetect with gsm (was g729) and it worked great. The tried WaitforSilence with gsm and worked great.

Odd thing is, I retried WaitforSilence with g729 and it worked. So I am back to where I started and have not been able to reproduce the error. Perhaps it is a g729 issue that is intermittent. Any thoughts?