VPMADT032 Echo Cancellation Module Troubles

Has anyone had success with the VPMADT032 Echo Cancellation Module?
I have had to turn it off which was very disapointing.
The module certainly cancels the echo but it cuts so harshly that my users were always asking people to repeat numbers etc. Digit strings such as credit cards etc. are chopped off.
I would like to get it working but as it is not a cheap item and should have been better that the software solution.

What Linux distro are you using?

I am using Ubuntu Gutsy


I am not sure if this will be helpful but I was testing a TDM2400 with the Hardware Echo Canceller and had a similar problem. The echo was gone but the voice was very choppy.

I was using Fedora Core 5 can’t remember what kernel; I spent a lot of time on it with the supplier and Digium and they could not resolve it.

I looked at what Digium would support for Asterisk Business Edition like RHEL 4 and CentOS 4X is supposed to be based on this.

So I changed to CentOS 4.5 (I did not change anything else) and the problem went away.

I put it down to one of the dependences in the OS. I did see on the bug tracker some reports of poor audio with certain versions of some dependencies.

I can’t prove any of this.

Thanks for the suggestion. I will investigate this solution.

Did you find a solution on this? I’m seeing the same issue on a CentOS 5.1 box with a TDM800P and a VPMADT032 making it impossible to have a conversation on a ZAP channel.

I have not been able to test the offered solution but it is a little discouraging that you have the same problem on CentOS 5.1.

Hi gazmac52,

Did you get it solved?

I have ordered a VPMADT032 to try.

Here is Digium’s response:

Your problems are known issues with zaptel and earlier. There are fixes available, but you need to use a development branch. To get this branch, issue the following commands (these require Subversion to be installed):

cd /usr/src
svn co svn.digium.com/svn/zaptel/team/sruffell/voicebus zaptel-SVN-1.4-voicebus
cd zaptel-SVN-1.4-voicebus
build_tools/uninstall-modules /lib/modules/$(uname -r) zaptel
make install

Reload the zaptel modules as you see fit (service zaptel restart, /etc/init.d/zaptel restart, etc.), and see if you have the same problems.

Note that these drivers should be officially released with version 1.4.10.

I have tried the development branch but it was not successful. Answer no longer worked.
We will wait for Zaptel 1.4.10 before trying again.

Well I tried 1.4.10 :cry:
It is not as choppy as before but still very poor.
Here is my test scenario:
Phone in from another line. Not via asterisk.
Place outgoing handset on the desk.
Lightly tap the outgoing handset and speak quietly over the incoming call.
With HWEC it chops most taps. Very unnatural to use.
With SWEC I can hear all taps.

I have switched back to MG2. I have tried to install OSLEC as an alternative but without success.
My confidence in this technology is greatly diminished.