Voicemail login config

dear,

i have one problem, for i leave the message to Bob1001.

and Bob dail this voicemail number 111 to retrive the messages.

the situation for now is that bob has to input his accout and password.

if bob use his own account number1001 to dial 111 to read message, how to config that he only have to input his password??

thx

Provide the mailbox name in the parameters to VoiceMailMain.

hi david,
really thx for your replying.

i make the

it don’t ask me to input mailbox number, ask me to input password.

then i want to skip password. tested the following three:
none of them work, can you have a look,thx again :smile:

exten => 52350000,n,VoiceMailMain(${self}@default) exten => 52350000,n,VoiceMailMain(s${self}@default) exten => 52350000,n,VoiceMailMain(${self}@default|s) exten => 52350000,n,VoiceMailMain([s]${self}@default)

Check option s for Voicemailmain. wiki.asterisk.org/wiki/display/ … ceMailMain

if you are on Asterisk 1.8 or later it should be VoiceMailMain([mailbox@[context]],s)

–Satish Barot