Voice quality issues after Asterisk upgrade from 1.4 to 1.6

I have an Asterisk server connected to a SIP trunk provider which has been running fine. We were developing code for the Digium Fax for Asterisk product and needed T38 support. We performed the upgrade on the Ubuntu Linux based server without any issues except modules. We moved all our existing modules to a backup folder and were able to get all our dialplans and applications running.

However, we suddenly now have voice quality issues on any voice file played. This includes our own recorded files, and the voice files which are included with asterisk.

I have monitored the server with the Linux top utility and cpu usage is not spiking, memory usage is not spiking. I have no idea what significant change is causing this problem but I could use any input or help that can be provided.

I see no errors or other issues in the SIP traffic or from Asterisk in my test or production code, but the voice quality issue is always there.

Please help. Thank you in advance,

  • wpr

Could perhaps be a hardware timer issue? Asterisk 1.6 doesn’t support Zaptel (now DAHDI) so if you have not replaced the virtual timer module ZTDUMMY with DAHDI_DUMMY, this could cause a problem.


I have tried installing DAHDI and using the res_timing_dahdi module and it still doesn’t solve the issue.

I have also checked my recordings and they are clear as a bell, so the only issue is that files played back have the problem.

If anyone has any help, I would greatly appreciate it.

Could you run DAHDI_TEST for a while and post the results?

Also post the output of lsmod.

I was able to finally get the problem resolved earlier tonite but didnt have a chance to post. I found an article indicating that the DONT_OPTIMIZE flag can cause poor conversion times on the codecs. When I tried core show translators , I could alaw and ulaw times to gsm where like 1001 or 2002 , and my other server has like 1 or 2 msec. So after recompiling with the DONT_OPTIMIZE, my voice files are playing fine now. I still have the server out of production, because I am still having trouble with faxing. I will post a seperate question about that.

Thank you for all for the help and input. - wpr

Glad you got this issue sorted, that’s an interesting issue!

Could you post the link to the article you found?


The article I found was:
mail-archive.com/asterisk-us … 95351.html