Vmail.cgi not working properly

I am having an issue with permissions. I have edited the app_voicemail.c file and changed 0700 and 0600 to 0770 and 0760, recompiled and reinstalled. This didn’t work so when vmails are written it still writes them as 0700 and 0600. If I manually change the permissions to 777 for dir and 757 for files I can manipulate them properly and without problem, until a new vmail arrives.
I am using slackware 11 kernel as my OS and asterisk 1.2.13. I am running asterisk asterisk when asterisk starts as suggested in another post about this same issue
forums.digium.com/viewtopic.php? … =vmail+cgi

when I attempted to do:
setfacl -Rm u:wwwrun:rwX /var/spool/asterisk/
I get an error:
setfacl: Option -m: Invalid argument near character 3

I’m not real sure where to go with this next. Any advice would be greatly appreciated.

Kind Regards

rather than manually changing the permission you can write
a script that does the same thing and execute it everytime a voicemail
is stored. For this “externnotify” needs to have the path of the
script file.
voip-info.org/wiki-Asterisk+ … email.conf