Using .call for outgoing


#1

Im trying to have automatic outgoing calls, and i was looking at the details about how to do it from voip-info.org/wiki-Asterisk% … dial%20out

But i cannot get it to work correctly, I want it to dialout to a cellphone or a regular house phone.
Is my channel set correctly?
IAX2/NuFone.net or do it need it like IAX2/user@NuFone.net ?
Also the number to dial, do i put that in the extension or in the Channel, because for a DISA it needs to be IAX2/user@NuFone.net/PHONE# , and if the channel needs to be IAX2/user@NuFone.net/PHONE# what would i put in the extension?


#2

Still cant get it to work… Is there anyone who knows make the call files please help me. I just can seem to get the chanel correct with IAX2

AIM: gamercjm8
MSN: gamercjm@hotmail.com


#3

CAn you post your IAX.conf so we can see your config?

Jag5x5


#4

working copy of a call file i’m using right now:

Channel: SIP/555
Context: from-inside
Extension: 9191329xxxx
WaitTime: 10
Priority: 1

Channel is the local asterisk device that is the ‘initiator’ of the call…so SIP/555 is the device that would be sending the call to the outside world.

Context is the context which you want asterisk to search for the extension

Extension is the number you want to dial. Note that I have mine prepended with a 91 as that is how our system recognizes long distance numbers. 9 is the LD prefix, and our telco requires LD numbers to have a 1 in front of them.

Waittime is how long asterisk will ring the channel before giving up

Priority I don’t know about, I always make it a 1.

Dropping this file will result in a call being placed to SIP/555, and after that device answers, Asterisk will dial the external number and bridge the two, so it would be the same as SIP/555 dialing 91913290xxxx…

Hope this helps.

W


#5

I think i have the call file correct, but now i get errors about extention…
Call File:

Channel: IAX2/Gamercjm@NuFone.net/PHONE# Callerid: 9518347815 MaxRetries: 1 RetryTime: 600 WaitTime: 300 Context: test Extension: s Priority: 1

And the errors are:

[quote]Mar 9 16:17:54 WARNING[2538] pbx_spool.c: Unable to set utime on /var/spool/asterisk/outgoing/1.call: Operation not permitted
Mar 9 16:17:54 VERBOSE[10939] logger.c: – Attempting call on IAX2/Gamercjm@NuFone.net/9518376142 for s@test:1 (Retry 1)
Mar 9 16:17:54 DEBUG[2525] channel.c: Avoiding initial deadlock for ‘IAX2/NuFone.net-1’
…9 More times…
Mar 9 16:17:54 WARNING[2525] channel.c: Avoided initial deadlock for ‘0x992f878’, 10 retries!
Mar 9 16:17:54 WARNING[2533] chan_iax2.c: Call rejected by 66.225.202.72: No such context/extension
Mar 9 16:17:54 DEBUG[2533] chan_iax2.c: Immediately destroying 1, having received reject
Mar 9 16:17:55 DEBUG[10939] chan_iax2.c: We’re hanging up IAX2/NuFone.net-1 now…
Mar 9 16:17:55 DEBUG[10939] chan_iax2.c: Really destroying IAX2/NuFone.net-1 now…
Mar 9 16:17:55 VERBOSE[10939] logger.c: – Hungup 'IAX2/NuFone.net-1’
Mar 9 16:17:55 NOTICE[10939] pbx_spool.c: Call failed to go through, reason 1
Mar 9 16:17:55 WARNING[10939] pbx_spool.c: Unable to set utime on /var/spool/asterisk/outgoing/1.call: Operation not permitted
[/quote]

And it says about “No such context/extension” but i have in the extension file just to test:

[test]
exten => s,1,Answer
exten => s,2,Wait(1)
exten => s,3,DigitTimeout(5)
exten => s,4,ResponseTimeout(10)
exten => s,5,Playback(please-enter-the)
exten => s,6,Playback(number)
exten => s,7,Hangup

#6

Hahaha I just figured out why it never worked…
For the number i want to call I have to enter 1+Phone#, I never had to before so i didnt put it in the call file. So it works now thanks for the help.