Unknown RTP codec 126 and Retransmission timeout

Hi Guys!
Thanks to you guys for previous help and especially david551. It will really help if you can explain the constant notice that i get in asterisk before it hangs up my calls with a Re transmission error message. I m using VICIDial v.8 in VMware 14 pro, using bridged network connection. My host PC is windows 10 SIP phone to SIP phone call works fine and i can ping my host and my VOIP domain as well. I m using a private connection with 4G LTE router. Is this some issue with asterisk or my installation method. As i have the following details with my firewall turned off, all required ports forwarded and my server in DMZ. When i dial through X-Lite it gives “failed to establish call” and VICIDial agent gives “dial time out contact your administrator”. Complete Wireshark trace of call is also provided in link(double click to download) please guide me so that i can attend the problem i face in proper manner.

Thankyou !

Wireshark Trace (double click the link to download)

The two messages are not related. Unknown codec means that Asterisk received media of a type it did not say it was prepared to receive. In particular, in this case, it is in a dynamically allocated range of codec numbers, so it has no idea what actual codec 126 represents.

Can it be possible that the message from my VOIP host is in higher range of codec than default in asterisk? Did you saw the wireshark file any conclusions from that…I actually wanna be sure which thing to change , Is it my PC or VOIP Provider or Router or just some details in sip.conf ? I can provide you with any details required for this task. I have also tried using STUN which can bind host laptop’s IP successfully but binding fails for VOIP’s domain or Asterisk server.


The peer should not send a codec number in the RTP that was not listed in the SDP sent by Asterisk.

X-lite uses it as a keep-alive mechanism. The message itself is harmless as we ignore it.

I can ignore that but the fact that i cannot make a call to any outside number keeps it calling in. I can only call to SIP phone extensions on same asterisk server,other end with re transmission critical seq no 102 followed by this codec.

It’s a NAT or firewall problem as mentioned. You have to break it down, verify traffic is going where it should, that it contains the correct addresses, and that traffic isn’t getting blocked. You need to experiment/learn the tools involved. There is no immediate answer or solution to the problem because you have to isolate it further.

I have already posted a wireshark file above and you can also have it in link below, tried using STUN but that also failed to bind with asterisks server(is there something i m missing about it), Blocked firewall, port forward the IP. Guide me if I can do anything more? Now i wanna change some hardware if i know where to start …

Wireshark Tracedouble click the link

I understand you posted a wireshark capture but without complete network understanding and knowledge of how everything is configured and used, that only scratches the surface.

Where should i start then?

Is Asterisk behind NAT? Have you configured it to know it is behind NAT? Have you examined the SIP signaling and confirmed the IP addresses are correct? Have you confirmed that the appropriate ports are open? Have you done a capture on the remote side to see where traffic is actually coming from? Have you done a capture on the remote side to see where it is sending any SIP responses?

If you are deploying VoIP these are things you need to learn how to do and also how to understand and interpret.

1.I tried NAT=yes in SIP.conf but don’t actually know if it is behind NAT because other laptops on the same
network can access it through its internal IP.
2. I have examined SIP signaling through wireshark ( Is there anything better please guide me)
3. Port are a bit confusing though, but i can use your help.
4.I don’t know how to do a capture on the remote side ( Please clarify )


  1. The nat=yes option is if a remote endpoint is behind NAT. It does not configure Asterisk for being behind NAT. There are guides online.
  2. I don’t have any guides for doing such a thing handy, but there are ones online.
  3. I don’t know your network, what is in use, etc so I can’t.
  4. The same way you’d do a capture on the local system. Wireshark, or looking at “sip set debug on”.

i think asterisk port 5060 udp is fine…
but cannot say the same for my host laptop which is using windows 10

I’ve given you what you need to do to try to isolate things. I don’t really have anything else to add. Others may but I can’t speak for them.

Thanks ! I will try to configure it and let you know if I succeed/