Unable to support trunking

Hy,i have next error when i try call over iax trunk on all machines (PC-1 and PC-2)!

[Apr 5 12:22:20] NOTICE[2611]: chan_iax2.c:9905 set_config: Ignoring bindport on reload
== Parsing ‘/etc/asterisk/users.conf’: Found
> doing dnsmgr_lookup for ‘216.207.245.47’
> doing dnsmgr_lookup for ‘Ip address 2’
[Apr 5 12:22:20] WARNING[2611]: chan_iax2.c:9366 build_peer: Unable to support trunking on peer ‘name_of_iax’ without zaptel timing
[Apr 5 12:22:20] WARNING[2611]: chan_iax2.c:9624 build_user: Unable to support trunking on user ‘name_of_iax’ without zaptel timing
> doing dnsmgr_lookup for ‘Ip address 2’
== Loaded firmware ‘iaxy.bin’

Please, can someone tell me what is the problem?

Best regards.

Iax Configuration:

PC-1

['name_of_iax]
nat=yes
type=peer
username=gredauser
secret=gredauser
auth=plaintext
host=IP_address_1
context=incoming_iax_greda
qualify=yes
trunk=yes
disallow=all
allow=gsm
allow=alaw

[name_of_iax]
nat=yes
type=user
username=gredapeer
secret=gredapeer
auth=plaintext
host=IP_address_1
context=incoming_iax_greda
qualify=yes
trunk=yes
disallow=all
allow=gsm
allow=alaw

PC-2

[name_of_iax2]
nat=yes
type=peer
username=gredapeer
secret=gredapeer
auth=plaintext
host=IP_address_2
context=incoming_iax_greda
qualify=yes
trunk=yes
disallow=all
allow=gsm
allow=alaw
port=4569
permit=0.0.0.0/0.0.0.0

[name_of_iax2]
nat=yes
type=user
username=gredauser
secret=gredauser
auth=plaintext
host=IP_address_1
context=incoming_iax_greda
qualify=yes
trunk=yes
disallow=all
allow=gsm
allow=alaw
port=4569
permit=0.0.0.0/0.0.0.0

Hi

First rule of fault finding. Read the error message as it may give an insite into the problem.

So you error message says [quote]Unable to support trunking on peer ‘name_of_iax’ without zaptel timing [/quote]

So what its telling you is that you dont have a zaptel timing source,

Now this can be either a zaptel card or if no cards are fitted then you need to compile zaptel with ztdummy enabled.

Ian

OK but i don’t have any zaptel card. I’m using only over LAN!

Hi Rule 2

Read replies in full :wink:

Ian

Hmm, i didn’t resolve this problem.

I’ve tried with modprobe ztdummy on PC1 and i have next output:

[root@centos ~]# modprobe ztdummy
[root@centos ~]# lsmod | grep ztdummy
ztdummy 9256 0
zaptel 190980 1 ztdummy
[root@centos ~]#

On PC2 i’m using SANGOMA CARD ant i think that i have timing on PC1.

Best regards

and
zttool says ? and zap show channels says ?

Why not just set trunking to no and accept the bandwith overhead

Ian

Excuse me, i’m big beginner :smile:

I’m just folowint tutorials from voip-info!

May you explain me more detailed. I need trunking because i must connect two locations!

You do not need to have trunking enabled set it to no and you will see. and to be honest if you dont have zaptel hardware then it will cause more trouble than its worth as its timed the same as a e1 so if timing slips it will sound bad.

Ian

I dont have zaptel hardvare on PC1 but on PC2 i have SANGOMA DRIVER.

On PC1 i have only ISDN PCI card for VOIP Gatways.