Unable to select G722


I’m new to the forum, so I hope i’m posting in the correct sub-forum.

I’m trying to set-up G722 for my clients, but it seems to be missing from SIP setting in the GUI…

I have check through the CLI ‘core show codecs’ and it is listed.

Adding the codec to sip.conf as ‘allow g722’, did not work.

Can somebody help out?


No GUI is supported on this board.

AsteriskGUI is well past end of life and FreePBX is supported at community.freepbx.org/

The G.722 codec module was probably not selected when Asterisk was built.

That also look like ye-olde Asterisk-GUI. So, I wouldn’t ask the FreePBX people for support on it either. No one supports that old code.

The GUI 2.1 came with the Synology Package.

I have tried to install FreePBX on the Synology, but I ran into too much dependencies, access-rights and different locations.

On topic, I have solved the issue by reviewing the debug output through CLI. Somewhere in the sip.conf was an empty ‘allow =’ after deleting it. The ‘allow=g722’ was picked up and it now works like a charm.


In that case, you need to ask Synology for support!

(The general suspicion is that most people suddenly discovering Asterisk GUI is dead are using Synology products.)