Unable to login at sip dialer ,using Asterisk 19.1.0 with AWS Ubuntu 18

I am facing an issue. don’t know how to solve this.
I am using Asterisk 19.1.0 with AWS ubuntu 18.

my private 172.31.0.xxx
my public 3.145.20.xxx

here is sip.conf




exten => 7001,1,Answer()
exten => 7001,2,Dial(SIP/7001,60)
exten => 7001,3,Playback(vm-nobodyavail)
exten => 7001,4,VoiceMail(7001@main)
exten => 7001,5,Hangup()

exten => 7002,1,Answer()
exten => 7002,2,Dial(SIP/7002,60)
exten => 7002,3,Playback(vm-nobodyavail)
exten => 7002,4,VoiceMail(7001@main)
exten => 7002,5,Hangup()

exten => 8001,1,VoicemailMain(7001@main)
exten => 8001,2,Hangup()

exten => 8002,1,VoicemailMain(7002@main)
exten => 8002,2,Hangup()

but still i am unable to login at sip dialer. what should i do now? how can i fix this error??

Please provide verbose level 5 logs.

What do you mean by “sip dialer”?

Why are you using a deprecated channel driver in a a leading edge version of Asterisk?

Did you actually build chan_sip, and load it? These no longer happen by default.

canreinvite was renamed to directmedia about a decade ago.

The yes parameter of nat was also deprecated many years ago.

Please explain why you need comedia and force_rport settings.

You say your local network is 172,31,0/24. Why do you have localnet set to 192.168.1/24?

Why are you using type=friend on your internal devices? (It is only needed if two devices share the same IP address.)

Why do you Answer calls early? (Can result in caller being charged more than necessary for the call.)

You will find it easier to maintain if you replaces 2 through 5, for the priority, with “n”, and use same => rather than the full exten specification, for those.

1 Like

thanks for the response.

actually, I am new at asterisk.

sip dialer means apps like microsip, zopier, portsip, xlite, etc for login .

so now which config should i set for proper connection?

The starting point, for internal calls, would be the first example in res_pjsip Configuration Examples - Asterisk Project - Asterisk Project Wiki

However, you should try to understand the configuration, not just blindly copy it.

1 Like

I forgot to ask why you are disabling direct media on internal calls.

The normal term for what you call “sip dialler” is “soft phone”.

If any of your soft phones share the same PC or share with Asterisk, additional considerations may apply.

1 Like

I missed the AWS in the subject. It looks like you have two NAT routers. That complicates things (and if your soft phones are not good enough, may require various options to be enabled to work round the poor NAT support. It may also mean direct media isn’t viable.

Generally, my advice would be to get the system working on a machine that is on your local network (raspberry pi’s are quite cheap). If you then go to a cloud solution, use a VPN, rather than exposing Asterisk and the soft phones to double NAT. To do this well will require a router that supports VPNs.

1 Like

I agree with @david551 - don’t use AWS if you’re just getting started because it adds additional networking that you have to understand and configure outside of Asterisk to have things work properly. You can move to it once you have the fundamentals down and understand things further.

1 Like

thank you. but I want to use AWS for Asterisk, what is the process of proper connection with softphones? I have seen some tutorials at youtube and read some articles about asterisk setup with aws. but not working for me.

could you help me, please?

if I use Twilio for sip trunk… maybe it will be easy to log in at softphone?

thanks brother, I have already tried with localhost, but now I want to try with AWS or AZURE or any other VPS provider. just tell me the process for connection with softphones.

I don’t have experience dealing with the AWS setup, so I can’t comment on that. Someone else may, and there have also been previous posts about running Asterisk on AWS.

1 Like

Make sure you edit inbound rules in the security group attached to your EC2 instance to allow udp traffic for 5060(for SIP signaling) and 10000-20000 (default rtp port range if you haven’t changed it in the rtp.conf).
Further, you shouldn’t be using chan_sip. Go with chan_pjsip which has been the default sip channel driver going forward with Asterisk development

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.