Unable to create channel of type 'SIP' (cause 20 - Unknown)

My sip.conf file


type = friend
username = 123
secret = brat_pwd
host = dynamic
context = from-sip

type = friend
username = 210
secret = user1_pwd
host = dynamic
context = from-sip

//uncommented the below line

include => from-sip
exten => 210,1,Dial(SIP/210,20)
exten => 123,1,Dial(SIP/123,20)

So on my softphone ( X-Lite ) I was able to register coz I saw the message Ready Your username is : 123

When I pressed 210 number to call my colleagues extension number ( hardphone ) in my office.

I saw call established but within fraction of sec It said 'Hung Up’
In my asterisk CLI:
Connected to Asterisk 1.6.0 currently running on bratpbx ( name of my linux machine ) (pid = 13983)
[Oct 16 13:14:33] WARNING[16416]: app_dial.c:1450 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Unknown)

I run asterisk-1.6 on Ubuntu-9.04 server and installed X-Lite phone on my Windows Laptop.

How do I fix this, to establish the call to number 210 and talk?

Help me!

i am having somewhat a similar problem. i have asterisk 1.4.33 running on debian lenny, i created a local network to run some tests. connected two hard phones (sip) to the network, and two softphones on another machine also connected to the network. everything worked fine, until i decided to test OpenSIPS.

i installed OpenSIPS on the same machine as asterisk, so now all my users’ registration is handled by OpenSIPS. i also added a rule, that every extension beginning with the star-key should be routed to asterisk on udp port 55555. asterisk is now listening to port 55555 (by using bindaddress = 55555 in sip.conf). so my problem is, when the call is routed to asterisk, i’m getting this “Unable to create channel of type ‘SIP’ (cause 20 - Unknown)” and the call fails.

any help would be much appreciated

i managed to solve this problem, apparently asterisk was still looking for sip users in the old mysql database (in where users used to register with asterisk directly) so the ip addresses changed. this is why asterisk couldn’t create the SIP channel.

i created a VIEW in the asterisk database (mysql) which imported the sip users info from another database proper to opensips.

i can call the softphones from the hard phones, but the hard phones can’t be called now. i get this sip response:

– Executing Dial(“SIP/soft-0000000a”, “SIP/left|15”)
– Called left
– SIP/left-0000000b is ringing
– Got SIP response 480 “Temporarily Unavailable” back from
– SIP/left-0000000b is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)

i will try to figure out what’s going wrong and submit the results