Trouble with Asterisk GUI

I have just installed Fedora 9 with the kernel. I installed zaptel-1.4.11, libpri-1.4.5 and Asterisk- Then I got the 2.0 version of the gui and installed it. After editing the http.conf and manager.conf according to the docs I ran make checkconfig. All seems to be well for the gui to run. So I started asterisk and tried to access it from another machine’s web browser. I noticed the note on checkconfig that said not to use bindaddr = 127,0.0.1 so I changed this to, the address of my new asterisk server. And I use the URL that checkconfig indicated would work. But I get nothing but an error message saying the URL is not available.

Can anyone tell me what to check for next?

please copy and paste that URL
I have noticed that there is an error in the way make checkconfig tells you the url:
asterisk: 8088asterisk/static/config/cfgbasic.html
notice the space after the : and before the 8? And how the last 8 and a are right next to each other?
it should look like this
asterisk:8088/asterisk/static/co … basic.html
I have filed a bug report on the 1.0 version of the gui and it was resolved but appeared again, and now it is in the 2.0 version as well. I will make another bug report and see if they can stop it from happening

Tell me about it. That was the first thing I found in the TFOT manual, page #250. The link to the svn site is obsolete. Then the link the TFOT manual tells you to use to access your server is also obsolete. Now add to it that the actual files used to install the asterisk gui have typos in the directions and you’ve got yourself a real case to fight the old RTFM replies that I frequently encounter.

I hadn’t noticed the extra space but I did notice there was no slash after the port number in the URL the install files listed.

My issue may run deeper but I hope not. I installed Fedora without Xorg because I wanted a simple * server without the bloat. But the docs all seem to be based on using the localhost address which means you need Xorg running to access the gui. I hope that access from another machine is possible. I changed the bindaddr to the IP address of my asterisk server instead of Is that correct or should I simply leave this off. Again, I only want a text based console for this * server.

Thanks for the assistance.

I am now downloading AsteriskNOW to see if that will resolve my problem. I really didn’t want to do this. I wanted a full blown version of Asterisk with the gui on a machine with Fedora. I don’t have any attachment to Fedora, in fact I’m a FreeBSD nut and that’s where my real * server resides. I’ve tried the gui with this machine but its still not fully ported over from the Linux world to FreeBSD. I like the solid performance I get from * on FreeBSD but in building a machine for our offices the IT guys are convinced that Linux will be more forgiving with it’s rich selection of drivers for other hardware. I have to confess that FreeBSD does not have the wide selection of drivers that Linux users enjoy. Still I wouldn’t trade my FreeBSD servers for anything except perhaps a date with a dozen supermodels… :smiley: